Try ERPNext Buy Support Partners Foundation

ERPNext bench start error

13:16:04 system           | redis_socketio.1 started (pid=1495)

13:16:04 system | redis_cache.1 started (pid=1498)
13:16:04 system | web.1 started (pid=1497)
13:16:04 system | redis_queue.1 started (pid=1496)
13:16:04 system | socketio.1 started (pid=1499)
13:16:04 system | schedule.1 started (pid=1500)
13:16:04 system | watch.1 started (pid=1509)
13:16:04 system | worker_short.1 started (pid=1502)
13:16:04 redis_cache.1 | 1501:C 25 Jun 13:16:04.935 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
13:16:04 redis_cache.1 | 1501:C 25 Jun 13:16:04.935 # Redis version=4.0.9, bi ts=64, commit=00000000, modified=0, pid=1501, just started
13:16:04 redis_cache.1 | 1501:C 25 Jun 13:16:04.935 # Configuration loaded
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.935 * Increased maximum numbe r of open files to 10032 (it was originally set to 1024).
13:16:04 redis_socketio.1 | 1505:C 25 Jun 13:16:04.936 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
13:16:04 redis_socketio.1 | 1505:C 25 Jun 13:16:04.936 # Redis version=4.0.9, bi ts=64, commit=00000000, modified=0, pid=1505, just started
13:16:04 redis_socketio.1 | 1505:C 25 Jun 13:16:04.936 # Configuration loaded
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.937 * Increased maximum numbe r of open files to 10032 (it was originally set to 1024).
13:16:04 redis_queue.1 | 1504:C 25 Jun 13:16:04.937 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
13:16:04 redis_queue.1 | 1504:C 25 Jun 13:16:04.937 # Redis version=4.0.9, bi ts=64, commit=00000000, modified=0, pid=1504, just started
13:16:04 redis_queue.1 | 1504:C 25 Jun 13:16:04.937 # Configuration loaded
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.938 * Increased maximum numbe r of open files to 10032 (it was originally set to 1024).
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.942 * Running mode=standalone , port=13000.
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.943 # WARNING: The TCP backlo g setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.943 # Server initialized
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.943 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.943 # WARNING you have Transp arent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo neve r > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /et c/rc.local in order to retain the setting after a reboot. Redis must be restarte d after THP is disabled.
13:16:04 redis_cache.1 | 1501:M 25 Jun 13:16:04.943 * Ready to accept connect ions
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.943 * Running mode=standalone , port=12000.
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.943 # WARNING: The TCP backlo g setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.943 # Server initialized
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.943 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.944 # WARNING you have Transp arent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo neve r > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /et c/rc.local in order to retain the setting after a reboot. Redis must be restarte d after THP is disabled.
13:16:04 redis_socketio.1 | 1505:M 25 Jun 13:16:04.944 * Ready to accept connect ions
13:16:04 system | worker_long.1 started (pid=1518)
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 * Running mode=standalone , port=11000.
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 # WARNING: The TCP backlo g setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 # Server initialized
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 # WARNING you have Transp arent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo neve r > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /et c/rc.local in order to retain the setting after a reboot. Redis must be restarte d after THP is disabled.
13:16:04 redis_queue.1 | 1504:M 25 Jun 13:16:04.945 * Ready to accept connect ions
13:16:04 system | worker_default.1 started (pid=1522)
13:16:06 socketio.1 | undefined:1
13:16:06 socketio.1 |
13:16:06 socketio.1 |
13:16:06 socketio.1 |
13:16:06 socketio.1 | SyntaxError: Unexpected end of JSON input
13:16:06 socketio.1 | at JSON.parse ()
13:16:06 socketio.1 | at read_config (/home/frappe/frappe-bench/apps/f rappe/node_utils.js:17:28)
13:16:06 socketio.1 | at get_conf (/home/frappe/frappe-bench/apps/frap pe/node_utils.js:28:2)
13:16:06 socketio.1 | at Object. (/home/frappe/frappe-bench /apps/frappe/socketio.js:10:12)
13:16:06 socketio.1 | at Module._compile (module.js:653:30)
13:16:06 socketio.1 | at Object.Module._extensions…js (module.js:664: 10)
13:16:06 socketio.1 | at Module.load (module.js:566:32)
13:16:06 socketio.1 | at tryModuleLoad (module.js:506:12)
13:16:06 socketio.1 | at Function.Module._load (module.js:498:3)
13:16:06 socketio.1 | at Function.Module.runMain (module.js:694:10)
13:16:06 system | socketio.1 stopped (rc=1)
13:16:06 system | sending SIGTERM to redis_cache.1 (pid 1498)
13:16:06 system | sending SIGTERM to redis_socketio.1 (pid 1495)
13:16:06 system | sending SIGTERM to redis_queue.1 (pid 1496)
13:16:06 system | sending SIGTERM to web.1 (pid 1497)
13:16:06 system | sending SIGTERM to watch.1 (pid 1509)
13:16:06 system | sending SIGTERM to schedule.1 (pid 1500)
13:16:06 system | sending SIGTERM to worker_short.1 (pid 1502)
13:16:06 system | sending SIGTERM to worker_long.1 (pid 1518)
13:16:06 system | sending SIGTERM to worker_default.1 (pid 1522)
13:16:06 redis_cache.1 | 1501:signal-handler (1593090966) Received SIGTERM sc heduling shutdown…
13:16:06 redis_socketio.1 | 1505:signal-handler (1593090966) Received SIGTERM sc heduling shutdown…
13:16:06 redis_queue.1 | 1504:signal-handler (1593090966) Received SIGTERM sc heduling shutdown…
13:16:06 system | worker_long.1 stopped (rc=-15)
13:16:06 system | watch.1 stopped (rc=-15)
13:16:07 system | worker_default.1 stopped (rc=-15)
13:16:07 system | schedule.1 stopped (rc=-15)
13:16:07 system | worker_short.1 stopped (rc=-15)
13:16:07 system | web.1 stopped (rc=-15)
13:16:07 redis_cache.1 | 1501:M 25 Jun 13:16:07.047 # User requested shutdown …
13:16:07 redis_cache.1 | 1501:M 25 Jun 13:16:07.047 * Removing the pid file.
13:16:07 redis_cache.1 | 1501:M 25 Jun 13:16:07.047 # Redis is now ready to e xit, bye bye…
13:16:07 system | redis_cache.1 stopped (rc=-15)
13:16:07 redis_socketio.1 | 1505:M 25 Jun 13:16:07.049 # User requested shutdown …
13:16:07 redis_socketio.1 | 1505:M 25 Jun 13:16:07.049 * Removing the pid file.
13:16:07 redis_socketio.1 | 1505:M 25 Jun 13:16:07.049 # Redis is now ready to e xit, bye bye…
13:16:07 system | redis_socketio.1 stopped (rc=-15)
13:16:07 redis_queue.1 | 1504:M 25 Jun 13:16:07.050 # User requested shutdown …
13:16:07 redis_queue.1 | 1504:M 25 Jun 13:16:07.050 * Removing the pid file.
13:16:07 redis_queue.1 | 1504:M 25 Jun 13:16:07.050 # Redis is now ready to e xit, bye bye…
13:16:07 system | redis_queue.1 stopped (rc=-15)

can help me?

Hi Did you manage to solve this error, i am facing the same challenge