ERPNext Conference 2019* ERPNext.com Blog

ERPNext and Opensuse


#1

Can ERPNext be installed on opensuse?
Did any one tried this?


#2

I think it will work, I tried in Debian based Linux it worked. :grinning:
Just try it.


#3

Hi,

I am trying on opensuse leap 42.3 64bit

I not able to get bench working

See the details below

t@linux-tj2a:~> git clone https://github.com/frappe/bench bench-repo
Cloning into ‘bench-repo’…
remote: Counting objects: 5659, done.
remote: Compressing objects: 100% (27/27), done.
remote: Total 5659 (delta 17), reused 15 (delta 8), pack-reused 5624
Receiving objects: 100% (5659/5659), 29.58 MiB | 509.00 KiB/s, done.
Resolving deltas: 100% (3588/3588), done.
it@linux-tj2a:~> pip install --user -e bench-repo
Obtaining file:///home/it/bench-repo
Requirement already satisfied: Click in
/usr/lib64/python2.7/site-packages (from bench==4.1.0) (6.7)
Requirement already satisfied: jinja2 in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (2.8)
Requirement already satisfied: virtualenv in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (15.2.0)
Requirement already satisfied: requests in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (2.11.1)
Requirement already satisfied: honcho in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (1.0.1)
Requirement already satisfied: python-crontab in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (2.2.8)
Requirement already satisfied: semantic_version in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (2.6.0)
Requirement already satisfied: GitPython==0.3.2.1 in
/usr/lib/python2.7/site-packages (from bench==4.1.0) (0.3.2.1)
Requirement already satisfied: MarkupSafe in
/usr/lib64/python2.7/site-packages (from jinja2->bench==4.1.0) (0.23)
Requirement already satisfied: python-dateutil in
/usr/lib/python2.7/site-packages (from python-crontab->bench==4.1.0)
(2.4.2)
Requirement already satisfied: gitdb>=0.6.0 in
/usr/lib64/python2.7/site-packages (from
GitPython==0.3.2.1->bench==4.1.0) (0.6.4)
Requirement already satisfied: six>=1.5 in
/usr/lib/python2.7/site-packages (from
python-dateutil->python-crontab->bench==4.1.0) (1.9.0)
Installing collected packages: bench
Running setup.py develop for bench
Successfully installed bench
You are using pip version 10.0.0, however version 10.0.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’
command.
it@linux-tj2a:~> bench init frappe-bench && cd frappe-bench
If ‘bench’ is not a typo you can use command-not-found to lookup the
package that contains it, like this:
cnf bench


#4

This might help


#5

Hi,
Thanks for quick responses,

Is this link still works, as it giving below error

https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh


#6

Check this page for the easy install of ERPNext.


#7

Hi,

Seems like installer doesnot support Opensuse 42.3, see the message
below

linux-tj2a:/opt/erpnext # python install.py --develop --user frappe
Sorry, the installer doesn’t support suse 42. Aborting installation!


#8

Hi,

seems like installer dont support

see the error below

linux-tj2a:/opt/erpnext # python install.py --develop --user frappe
Sorry, the installer doesn’t support suse 42. Aborting installation!


#9

Supported Versions:


#10

Thanks for the response,
I did seen the supported versions list,

Was working around with opensuse and since centos and opensuse both are rpm based,
hence was wondering if ERPNext will work on that.

Thankyou