Employees not showing

Currently, only the Administrator user can see the full list of employees in our system. Employees who are also Users can only see themselves, even though they are HR managers and even if they are System Managers.

The ‘Create User Permission’ option under Employee looked promising but regardless of how it’s set, the Users don’t show. No filters come into play. Thoughts?

Under users module if you go to user permissions, there will be Allow - employee option.

Create a test user and try deleting this permission document of Allow - employee for that test user. It worked for me.

So, this worked…sort of. I found the ‘Employee’ permission for the user in question. Deleting it caused them to be able to see all employees as expected. However, within 24 hours, the permission reappeared. I’m guessing that one of the role permissions is causing this to be repopulated. Any idea which one?