Email setup help

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.


I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext’s SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a “Message Sent” dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the “Auto Email id” field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary <pa...@virtual-gt.com> wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>

Hi Anand,


We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use “Everything” for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server
    smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the “Email Settings” page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of “Auto Email Id” field.

“Auto Email Id” should be an email id which is used in the “From” field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, “Auto Email Id” needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext’s SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a “Message Sent” dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the “Auto Email id” field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>

Hi Paul,

If you are getting the response "Message Sent", then the mail is getting sent, but it could've gone into the spam mail folder. 

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as "Not Spam".

If you are not getting "Message Sent" as response, you should've got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary <pa...@virtual-gt.com> wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use "Everything" for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>


I do not get “Message Sent”. I am sending to my alternate email address so it’s not going into spam… I checked.


There is NO error message. After I press send, the spinner runs for about 1/2 second, after which I am returned to the main window. The email is never received.

I am able to get email from pressing the Assign button to create a to-do. I presume this is a separate mechanism, but does show that erpNext is able to send an email to the same alternate address as used above.

I currently have the Outgoing Email form filled out for my Google Apps email info. According to the manual, I should just leave this all blank. That results in the same problem.



On Saturday, August 4, 2012 11:45:42 PM UTC-7, Anand Doshi wrote:
Hi Paul,

If you are getting the response “Message Sent”, then the mail is getting sent, but it could’ve gone into the spam mail folder. 

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as “Not Spam”.

If you are not getting “Message Sent” as response, you should’ve got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use “Everything” for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server
    smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa…@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the “Email Settings” page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of “Auto Email Id” field.

“Auto Email Id” should be an email id which is used in the “From” field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, “Auto Email Id” needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext’s SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a “Message Sent” dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the “Auto Email id” field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>


Dear sir,

Pl do not send any more mails since this programme has faild to cater our requirement and we have dropped to implement this programme.

Regards
sriman







On Sun, Aug 5, 2012 at 2:19 PM, Paul Stary <pa…@virtual-gt.com> wrote:

I do not get “Message Sent”. I am sending to my alternate email address so it’s not going into spam… I checked.

There is NO error message. After I press send, the spinner runs for about 1/2 second, after which I am returned to the main window. The email is never received.


I am able to get email from pressing the Assign button to create a to-do. I presume this is a separate mechanism, but does show that erpNext is able to send an email to the same alternate address as used above.

I currently have the Outgoing Email form filled out for my Google Apps email info. According to the manual, I should just leave this all blank. That results in the same problem.



On Saturday, August 4, 2012 11:45:42 PM UTC-7, Anand Doshi wrote:
Hi Paul,

If you are getting the response "Message Sent", then the mail is getting sent, but it could've gone into the spam mail folder.

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as "Not Spam".

If you are not getting "Message Sent" as response, you should've got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use "Everything" for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server - smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>



Dear Sriman,

Will unsubscribe you from this list asap.

Sorry for your bad experience. Unfortunately we cannot control your experience via a third party implementer, that we admit we recommended. We will be more careful next time in recommending customization partners. This only reinforces our belief that customization for small businesses is a bad idea.

To clarify for other readers on this list, 7Hills were implementing ERPNext not via us but via a 3rd party.

Hope to see you back sometime.

best,
Rushabh


-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 06-Aug-2012, at 10:56 AM, Srimannarayana Seven Hills <sh...@gmail.com> wrote:

Dear sir,

Pl do not send any more mails since this programme has faild to cater our requirement and we have dropped to implement this programme.

Regards
sriman






On Sun, Aug 5, 2012 at 2:19 PM, Paul Stary <pa...@virtual-gt.com> wrote:
I do not get "Message Sent". I am sending to my alternate email address so it's not going into spam... I checked.

There is NO error message. After I press send, the spinner runs for about 1/2 second, after which I am returned to the main window. The email is never received.

I am able to get email from pressing the Assign button to create a to-do. I presume this is a separate mechanism, but does show that erpNext is able to send an email to the same alternate address as used above.

I currently have the Outgoing Email form filled out for my Google Apps email info. According to the manual, I should just leave this all blank. That results in the same problem.



On Saturday, August 4, 2012 11:45:42 PM UTC-7, Anand Doshi wrote:
Hi Paul,

If you are getting the response "Message Sent", then the mail is getting sent, but it could've gone into the spam mail folder. 

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as "Not Spam".

If you are not getting "Message Sent" as response, you should've got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use "Everything" for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>




Dear Paul,

The bug relating to email is fixed. You should be able to send the mails now.

best,
Rushabh

On 05-Aug-2012, at 2:19 PM, Paul Stary <pa...@virtual-gt.com> wrote:

I do not get "Message Sent". I am sending to my alternate email address so it's not going into spam... I checked.

There is NO error message. After I press send, the spinner runs for about 1/2 second, after which I am returned to the main window. The email is never received.

I am able to get email from pressing the Assign button to create a to-do. I presume this is a separate mechanism, but does show that erpNext is able to send an email to the same alternate address as used above.

I currently have the Outgoing Email form filled out for my Google Apps email info. According to the manual, I should just leave this all blank. That results in the same problem.



On Saturday, August 4, 2012 11:45:42 PM UTC-7, Anand Doshi wrote:
Hi Paul,

If you are getting the response "Message Sent", then the mail is getting sent, but it could've gone into the spam mail folder. 

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as "Not Spam".

If you are not getting "Message Sent" as response, you should've got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use "Everything" for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.

I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>



Ohk…

On Mon, Aug 6, 2012 at 11:30 AM, Rushabh Mehta <rm…@gmail.com> wrote:
Dear Sriman,

Will unsubscribe you from this list asap.

Sorry for your bad experience. Unfortunately we cannot control your experience via a third party implementer, that we admit we recommended. We will be more careful next time in recommending customization partners. This only reinforces our belief that customization for small businesses is a bad idea.

To clarify for other readers on this list, 7Hills were implementing ERPNext not via us but via a 3rd party.

Hope to see you back sometime.

best,
Rushabh


-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 06-Aug-2012, at 10:56 AM, Srimannarayana Seven Hills <sh...@gmail.com> wrote:

Dear sir,

Pl do not send any more mails since this programme has faild to cater our requirement and we have dropped to implement this programme.

Regards
sriman






On Sun, Aug 5, 2012 at 2:19 PM, Paul Stary <pa...@virtual-gt.com> wrote:

I do not get "Message Sent". I am sending to my alternate email address so it's not going into spam… I checked.


There is NO error message. After I press send, the spinner runs for about 1/2 second, after which I am returned to the main window. The email is never received.


I am able to get email from pressing the Assign button to create a to-do. I presume this is a separate mechanism, but does show that erpNext is able to send an email to the same alternate address as used above.

I currently have the Outgoing Email form filled out for my Google Apps email info. According to the manual, I should just leave this all blank. That results in the same problem.



On Saturday, August 4, 2012 11:45:42 PM UTC-7, Anand Doshi wrote:

Hi Paul,


If you are getting the response "Message Sent", then the mail is getting sent, but it could've gone into the spam mail folder.

These days, the email providers are over-protective and sometimes send legitimate emails to spam. Please check your spam mail folder and if found, please mark it as "Not Spam".

If you are not getting "Message Sent" as response, you should've got an error message defining the problem. Please state that message here so that we could identify the exact problem.

Thanks,
Anand.

On 05-Aug-2012, at 12:10 PM, Paul Stary wrote:

Hi Anand,

We signed up for the 5-user hosted plan and on the 5th day of our 30 day trial. I think that means we are an SaaS customer.

Not sure what you mean by virtualbox copy and I have certainly not installed in on my computer.

I do not find a conf.py file on my computer (I use "Everything" for searching and have it set to include system and hidden files) but presume that would NOT be found if I am an SaaS customer.

I now understand the Auto Email id field. That does not solve my problem. Still have not outgoing email service.

I have tried using my Google Apps email info as follows:
  • Outgoing Mail Server - smtp.gmail.com
  • Mail Port - 587 (hangs if I use Port 465)
  • Use SSL - Yes (checked)
  • Login ID: pa...@mydomain.com
  • Mail Password: my Google Apps email password
I am able to save the settings with the information above without any error message. Still no outgoing email. Any other suggestions?

Thanks for your help.
-----
Paul Stary


On Saturday, August 4, 2012 9:49:58 PM UTC-7, Anand Doshi wrote:
Hi Paul,

Thanks for your enthusiasm with erpnext.


It seems that you are either using the virtualbox copy of erpnext or have installed it on your own computer.

The default settings for email are provided only for our SaaS customers and are specified in the conf.py file. You will need to enter the correct settings in the "Email Settings" page for email to work, if you are not our SaaS customer.


From your screen shot, I can see that you misunderstood the meaning of "Auto Email Id" field.

"Auto Email Id" should be an email id which is used in the "From" field of an email, when trying to send a system generated email, like a welcome mail sent after addition of a user. Hence, "Auto Email Id" needs to be a valid email id you / your company owns.

When you try to save your email settings, erpnext will validate your settings by connecting to the email server and logging into it using the Login Id and Mail Password specified. Once these settings are successfully saved, you should be able to send emails from within erpnext.

Please try this and let us know if you are able to successfully enable emails in erpnext.


Thanks,
Anand Doshi
Developer

On 05-Aug-2012, at 7:16 AM, Paul Stary wrote:

My first but certainly not the my last post on this group. I am new to erpNext but loving every minute of setting it up. An amazing tool! Like many of you, I have been looking for this product for many years.


I cannot get Outgoing Email to work, either via our Google Apps SMTP account info (following settings recommended in earlier posts), or by leaving Outgoing fields blank (as suggested in the manual, bottom of pg. 51, thereby using erpNext's SMTP relay service.

I tried sending emails from the sidebar in the demo and it worked great. I received a "Message Sent" dialog to confirm the email. Have never seen that on my setup and never receive the email (I am sending to my own alternate email address).

Any help on how to setup the Outgoing Email would be greatly appreciated. I am probably doing something wrong.

The only field that contains any data in this area is the "Auto Email id" field, where I have just entered my name. Not clear on what the intent of this field is.

Screen shot of my setup is attached.
<Outgoing Email Setup Screen 1.gif>





Hi, My erpnext installation is sending system mails without any issue,but when i try to send any po or invoice or any other kind of mail using same user id (Admin id), no mail is sent actually, though on screen it confirms email sent.Kindly provide some way to troubleshoot the real problem.

Your scheduler is not working. Share your production setup and post on a new thread.