Email Setting Changes On Its Own

Hi

I’ve setup one of my email account on the ERPNext server to pull emails from the email server and also send alerts etc through this same account.

Without any reason, the Email Account setting changes and creates a To-Do task - Unable to fetch email. Incorrect email settings. The system unchecks the “Enable Incoming” check-box on this email account. When I login and re-enable the incoming settings and save, it starts to work. But after few hours, it again changes back to unchecked “Enable Incoming”.

Any suggestion what could be triggering this auto change in setting?

PS: I think it is related to scheduler as there is nothing else on the server that runs and executes commands automatically on the server. But I don’t know the repercussions of disabling the scheduler.

@saurabh

The problem that you have mentioned happens, if the connection between ERPNext and mail servers is not consistent or If the scheduler interval is set to pull or push emails too frequently from the servers. For example, check this,

https://support.google.com/mail/answer/14257

For testing purpose, you can try setting scheduler interval to a higher value than your present.

Also, a fix has been pushed to Frappé Develop branch to retry before resetting the values,

Hi @shreyasp

Thanks for your response & the update in the developer branch.

For your information, I am running production and facing this issue.

Additionally, I received a notification that there is a email pull error but as per schedule, I received Digest at 00:01. It means outgoing keeps working but incoming throws an error.

Can you please advise how to change scheduler interval to a higher value?

Check the System Settings on your site to update the scheduler interval. You can update Background Workers section for changing the time interval.

Thanks @shreyasp

From System Settings, I’m either able to enable scheduler OR disable schduler. I’m not able to change Background Workers time interval (see attached screen-shot). Is there a way I can do it from terminal?

has this been pushed to production i just discovered that my incoming "Enable Incoming " is getting unchecked without us doing it a real problem…