Email Inbox - Sent e-mails not being saved under "Sent Mail"

Hello,

I configured the Email Inbox correctly, as incoming and outgoing mail is working (service provider is Zoho, document type is set to “Communication”).

Incoming e-mails are working fine.

Outgoing e-mails are sending OK.

However, e-mails are not appearing in the “Sent Mail” box.

Any ideas?

As far as my knowledge
outgoing will be put in to the Communications
not in to the Outgoing Emails.

Hope this helps.

I do see emails i forward or reply to in my Sent folder . thats is the sent folder in Email Inbox , NOT in any other mail client. I asked this question during the V8 email inbox webinar which they confirmed

Hi everyone,

This is still not working.

I have my accounts set up correctly, but whenever I go to “Email Inbox” under “Sent” (link is myservername/desk#List/Communication/Inbox/Sent), it shows “No Emails”.

I’m using Zoho via IMAP for my incoming mail.

1 Like

I already mentioned this kind of subject:

In e-mail inbox if you choose the “Sent” filter then there is NO email.

If you go on left side menu “Sent Mail” - which is not reachable in IOS phone! - then you can
switch to “Inbox” or “Sent” filter and you see the incoming and outgoing email as should be.

Any news on this?

Works for me. Check your mail logs on erpnext for errors. When Sending an email it should say sent when it is

You could try mailgun or one of those services perhaps instead

Well i read your em,ail again, and yes i have the same issue with the filters. Please can you crate a github issue for this with your description and screenshots in possible.

I’ve checked the develope console and i dont get any errors there

If in your ERPNext account, the Email Inbox is configured for one account, but as per the Email Account, default outgoing email gateway is set to another,. This could be the reason, sent emails are not appearing in the Email Inbox view. In my test account, since my ID, email inbox and outgoing email gateway is all the same, it is correctly showing sent emails in the inbox view as well.

Another reason could be for the copy of emails on the server, you should look for the setting of your email service provider. In Gmail, it is provided by default. In other services like WebMail, you have to specifically enable the feature of leaving a copy of an email on the email server always. Perhaps you can check the setting of your emails service, as it must be configured at that end.

Hope this helps.

@ArundhatiS

Thank you for your toughts.

The first reason seem to cover my problem.

I set one domain, but the incomming is different.
Then it works as should be.

Question:

I should set up more domains paralell to be able to switch between ALL the incomming and outgoing all of my email under Email menu?

@ArundhatiS

I tried again with a domain + a different outgoing gateway.

If I’m in the Email inbox view there is not appearing the sent emails if I switch to it.
As you explained.

If I go to the email inbox in the left side menu then I can switch between the inbox and sent emails.

Why this difference on the two?

Now the lately version
ERPNext: v8.8.3 (master)
Frappe Framework v8.7.5 (master)
works as should.

You able to switch between the
incomming and outgoing
in the filters.

Please close this subject.

I FINALLY figured this out.

So apparently my user name lost user permission access to Communications.

This seemed to happen as the result of a change where the role “Super User Email” was added.

Once I added this role, and added my username to it, I was finally able to get this fixed.

Hopefully someone will find this useful. I think the lack of “Super User Email” is a bug somewhere in the upgrade process.

2 Likes