Email Domain Setup Issues

Seem to be struggling to correctly configure the new version 8 email domain features. We have our own domain (av8tech.com) which is a google GSuite hosted domain.

I have tried to setup the new email domain using the default gmail imap and smtp server info but when I add a new user and specify the av8tech.com email domain it says “invalid email or password”.

Are there any others who have private domains which use google for mail and have been able to successfully configure the new email domain settings to work? Any insight into the correct steps would be greatly appreciated.

Aside from the issue with Email Domain, does simply creating an Email Account without a Domain work for you?

I am able to create and send emails using a gmail.com email address, but am not able to use one from our av8tech.com domain. Our corp mail is provided through Google and I found that our DNS uses a CNAME of ghs.googlehosted.com for mail. I suspected that we needed to use this for the email server instead of imap.gmail.com but it just says “request timed out”.

If I try to setup an email account for a person @av8tech.com it says “email domain not configured for this account, create one?” So it is required that I get this setup first.

In summary, email only works if we use a @gmail.com address. Won’t work with a @av8tech.com address.

Hi @AV8

I am also having the same issue with our domain at godaddy.
DId you find any solution or workaround for this?

Thanks!

You have to check less secure applications in gsuite setting and activate the option.

Regards

Did you find a solution for godaddy e-mails? I’m facing the same issue.

Im using now version 9. And ot works correctly.
However, if I think I had to use POP, not IMAP, without SSL it will work.
Then activate SSL, and save, and it will work

I think that was the way it worked for me in version 8

@memo2d,
Could you please elaborate? Were you able to solve the issue?
If yes, can you please share more details. I too am not able to configure godaddy email. I tried the configs used in Outlook client as well as thunderbird. Tried secure as well as not secure settings. Nothing seems to work.
On side note, I could configure gmail account.

@Francisco_Garcia

@AV8 @memo2d
Hi Guys ! Inorder for this to happen for Gsuite (now called Google Workspace)…

  1. Go to Less-secure-apps and turn on. (if it shows this is managed by your administrator. Sign in admin.google.com with the superadmin account and search for less secure apps and turn the setting to be managed by each user. Now go back to less secure apps and you will get a turn on/off button)
  2. Once that is done, go to gmail -> Settings - >See all settings-> Forwarding IMAP/Pop Settings -> Turn on IMAP.

ERPNEXT

  1. Go to email domain list - >Add new->
    Example email address- someaccount[at]yourdomain[dot]com
    Email server: imap[dot]gmail[dot]com
    user imap -> Tick on
    user SSL -> Tun on
    Port -> 993
    Attachement limit- 25MB
    smtp server ->smtp[dot]gmail[dot]com
    use TLS -> Untick
    Use SSL for outgoing -> Tick
    Append -> Untick
    Port-> 465

Save

Now you can add user-

PS: Incase you have 2 step verification, when you create user account you will still face error. Inorder to fix that you need to go to Manage Account on google -> Security -> App Passwords -> Select App (Other) -> Select Device (Other) You can type in erpnext. a password will be generated and this can be used when you setup the account.