Try ERPNext Buy Support Partners Foundation Foundation Members

Email Alert not working on DocType Custom Date Field

Hi,

I just had an issue on email. It works on notifications of new user signup and password updates, as well as Chat email and Comment Email. The problem is it does not work on Doctype email and email Alert.

Here’s screen where email is not working:

The same is not being queued on Email Queue.

Here is my Frappe Version:

//Thanks

Hello,

The screenshot of Menu indicates that Email option is available. Can you please indicate specific Doctype where it’s not working, like Sales Order, Invoice etc.? Any error message?

Hi. Already fixed this. I forgot to add the Email Option on the email field I have created. Thanks.

Hello jeffbanquil,
I’m facing the same issue on 10th version.
Please can you tell me the fix.

I only added Email on options of the email field i have created.

Use Case: Some of the suppliers give us the discount due date, which means that if we pay in 10 days from Bill date we get 1% cash discount. If not the usual due date is 30 days. While booking the purchase invoice, we capture 30 days date under the Due date filed, however, we also needed additional date field to capture the discount due date - For this, I have added a custom field under Purchase Invoice as “Discount Due Date” field with Date as the field type.

Now I need to set up a reminder based on this discount due date, one day prior to the accounts team. So they make the necessary fund arrangement and pay to avail 1% cash discount.

I set up my email alert as below:

On clicking “Get Alert for Today”, i see this eligible Purchase Invoice

But, in my Email Queue, i don’t see this email getting sent. My email setup is fine, and other composed emails are getting sent. See here.

Anyone finds a configuration issue here? Please guide me

Hi Team ,
Same issue i am facing for the on submiting the sales order.i have create one sales order and when i submit it it submit .but the email not receive to the receiver .even mail is not found in queue also…,but when manually i do this the mail is queue and within 2,3 min .it will be send.

I want this functionality in my local machine ,but it is not working automatically…
please suggest the suitable solution for the same .

Thanks