ERPNext.com Frappe Cloud Documentation Partners Frappe School Public Chat

Easy install setup guide for erpnext installation on Ubuntu 20.04 LTS. With some modification of course

  1. If you face ModuleNotFoundError: No module named ‘erpnext .

Follow this https://medium.com/@binodpaneru23/setting-up-erpnext-in-mac-os-c475466f5403

Based on this doc I used

frappe-bench/env/bin/pip3 install -U -e ./apps/erpnext

Thanks @arun992 for steps 5 and 6

  1. if you get stuck with Cython is required to compile pandas from a development branch. error.
    Check this post [https://github.com/frappe/erpnext/issues/22424 ]

Based on this doc use the following commands:

frappe-bench/env/bin/pip3 install pandas==0.24.2
frappe-bench/env/bin/pip install numpy==1.18.5

After this use

frappe-bench/env/bin/pip3 install -U -e ./apps/erpnext

Oncef inished the erpnext installationcontinue with the command

sudo frappe-bench/env/bin/python3 temp --production --user frappe --mariadb-version 10.5 --verbose

1 Like
frappe-bench/env/bin/pip3 install -U -e ./apps/erpnext
ERROR: ./apps/erpnext is not a valid editable requirement. It should either be a path to a local project or a VCS URL (beginning with bzr+http, bzr+https, bzr+ssh, bzr+sftp, bzr+ftp, bzr+lp, bzr+file, git+http, git+https, git+ssh, git+git, git+file, hg+file, hg+http, hg+https, hg+ssh, hg+static-http, svn+ssh, svn+http, svn+https, svn+svn, svn+file).

Note also I haven’t a Mac, but a Windows 10 wls2 envirnoment.

@Ido_Traini Erpnext is not made for working on such platforms. It is highly recommended to use the Linux based OS for installation and testing ERPNEXT.

However there are some brave souls who has tried making ERPNEXT work with WSL environment, please check the link below for more understanding.

@Nikunj_Patel
wsl2 is a virtual machine and there are no reasons because erpnext cannot run on it. There are details to resolve, sure, as always when you want to work with linux.
I’m trying to do it, for me and for anyone want to use erpnext on wls2. I think this is the right approach on open-source material, but this is your topic and I will stop to post questions and found solutions.

Only a note: regarding the command:
frappe-bench/env/bin/pip3 install -U -e ./apps/erpnext

perhaps it can be useful to know that it is not correct, at least on my platform. Correct command is:

frappe-bench/env/bin/pip3 install -U -e ./frappe-bench/apps/erpnext

regards.

@Ido_Traini yes you are right to use open source as you deem fit, but as instructions from the core developers are clear that the current version installation via install.py script works best with ubunutu 18.04, Centos8 and debian. Anything else would require some hack. This is what I tried to do when I installed it on ubunut20.04. (this installation procedure is true for ERPNEXT 12 version. Version 13 might need some tweaking because there is lots of new things in it.)

Since all this OS behaves little different than others + lots of custom application installed on any given machine, it is impossible to have installation script to have 1 size fits all mode.

I have already shared a post of installing ERPNEXT12 on WSL on windows 10. If that might help you in anyway.

Anyways best of luck in your troubleshooting and if at all you find something working with your WSL please create a post and share it with community, just in case some core team developer might get something important from it in future.

@Nikunj_Patel
I’ve just concluded with success installation on Ubuntu 20.04 in wls2 environment. Your suggestions contain some command errors but with minimum tweaking it is possible.

now I will retry the procedure in a fresh installation and I will create a new post as reference for whatever want o need to do the same.
Thanks for your work.

Glad to know this works for you. I am a novice and tried it and didn’t work and since I’m unabke to dual boot my PC I’m unable to try it out. I will be looking forward to your post where you have a fail proof approach and also possible you try for v13?

@tobsowo sure. I will try for a fresh install later this week and post my sequence, but it will be mostly similar at the @Nikunj_Patel instructions.

Also, I’ve tried with this: Install v13 Production on Ubuntu 20.04 VPS - This is how I did it "Easy Install" script
and I was able to complete the installation (but I have actually some problems with DB).

In both cases, just remember to install this script before: https://github.com/DamionGans/ubuntu-wsl2-systemd-script for activate the systemd.

1 Like

Cool. I will check that out. Thank you.

I tried using the script to activate systemd but did not work, here is what I have

oluwatobi@Oluwatobi-PC:/mnt/c/Users/TOBI/ubuntu-wsl2-systemd-script$ bash ubuntu-wsl2-systemd-script.sh
Get:1 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Ign:2 http://apt.vestacp.com/focal focal InRelease
Get:3 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [619 kB]
Hit:4 http://archive.ubuntu.com/ubuntu focal InRelease
Get:5 http://nginx.org/packages/mainline/ubuntu focal InRelease [2861 B]
Err:6 http://apt.vestacp.com/focal focal Release
  404  Not Found [IP: 104.236.66.100 80]
Get:7 http://nginx.org/packages/mainline/ubuntu focal/nginx amd64 Packages [25.0 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:9 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [126 kB]
Get:10 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [7436 B]
Get:11 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [181 kB]
Get:12 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [26.8 kB]
Get:13 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata [396 B]
Get:14 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [551 kB]
Get:15 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:16 http://security.ubuntu.com/ubuntu focal-security/universe Translation-en [82.1 kB]
Get:17 http://security.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata [10.7 kB]
Get:18 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages [14.8 kB]
Get:19 http://security.ubuntu.com/ubuntu focal-security/multiverse Translation-en [3160 B]
Get:20 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata [340 B]
Get:21 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [944 kB]
Get:22 http://archive.ubuntu.com/ubuntu focal-updates/main Translation-en [216 kB]
Get:23 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [13.2 kB]
Get:24 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [206 kB]
Get:25 http://archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [30.6 kB]
Get:26 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [440 B]
Get:27 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [759 kB]
Get:28 http://archive.ubuntu.com/ubuntu focal-updates/universe Translation-en [162 kB]
Get:29 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [17.0 kB]
Get:30 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages [21.6 kB]
Get:31 http://archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en [5508 B]
Get:32 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata [600 B]
Get:33 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages [4032 B]
Get:34 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 c-n-f Metadata [224 B]
Reading package lists... Done
E: The repository 'http://apt.vestacp.com/focal focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

SUCCESS: Specified value was saved.

SUCCESS: Specified value was saved.

Did you tried to control if all ok? You have to restart Ubuntu e launch systemctl. If it runs (quit with “q”), you have installed the script

Sorry, didn’t get that can you help with the command to run?

I uninstalled the WSL Ubuntu and install a fresh one and the script worked. Then I used this script to install https://gist.github.com/daif/f356ee4a40b1ca083ec8de9cb45ba174 although there were few error but it successfully install but unfortunately, I can access ERPNext on my browser.

how to do this:

Fixed that by copying the snippet for wkhtmltox again to /tmp/.bench/playbooks/roles/wkhtmltopdf/tasks/main.yml.

I honestly don’t remember anymore. I’ll try to recreate over the weekend if I find time, but I can’t guarantee that.

1 Like

I installed it. Just change ubuntu version

hi @Nikunj_Patel can u help me out to install the erpnext

hello, how can we change the ubuntu version on the server? Currently, it’s 20.04 and I want to downgrade it to 18 or 19.
Thank you

Ran setup on Ubuntu 20 (Installed on Android through Andronix-Termux) and every time it ran into below error.

fatal localhost failed error TASK LOCALE

I am frustrated, it’s been 3 days since I am trying to achieve this, even resinstalled the OS multiple time.

Already using ERPNEXT through VM on windows without any trouble.

What am I doing wrong, or what if ERPNEXT through termux isn’t possible at all?

I believe it’s not possible to downgrade the version of Ubuntu, you may have to install fresh.