Easy Install Script stuck on "Create New Site"

I started the easy install script yesterday morning (approx 22 hours ago) on a brand new Ubuntu 16.04 VM (the only change made to the VM was to install Python 2.7). It has been stuck on “Create New Site” for probably 20 hours now.

Looking at HTOP the only command I can see running is

/usr/bin/python /usr/local/bin/ansible-playbook -c local production/install.yml -e @/tmp/extra_vars.json --become --become-user=frappe

I ran the script with the --production and --user frappe flags as root.

Any assistance on getting this working would be greatly appreciated. I should be able to get a new clean VM set up if needed.

Run it again, with the --verbose flag. That will give you more info on where it got stuck.

It skipped the “Create New Site” step on the second run (it looks like all the files are there but hard to tell). It’s now stuck on the “Install erpnext app” step. In htop the exact same process as before is running. Last few lines of console output are:

TASK [Install erpnext app] ******************************************************************************************************************************************************************
task path: /tmp/.bench/playbooks/production/includes/setup_bench_production.yml:57
Using module file /usr/local/lib/python2.7/dist-packages/ansible/modules/commands/command.py
<> EXEC /bin/sh -c '( umask 77 && mkdir -p "` echo /tmp/ansible-tmp-1516975940.36-226939758799942 `" && echo ansible-tmp-1516975940.36-226939758799942="` echo /tmp/ansible-tmp-1516975940.36-226939758799942 `" ) && sleep 0'
<> PUT /tmp/tmp5Mabqk TO /tmp/ansible-tmp-1516975940.36-226939758799942/command.py
<> EXEC /bin/sh -c 'setfacl -m u:frappe:r-x /tmp/ansible-tmp-1516975940.36-226939758799942/ /tmp/ansible-tmp-1516975940.36-226939758799942/command.py && sleep 0'
<> EXEC /bin/sh -c 'sudo -H -S -n -u frappe /bin/sh -c '"'"'echo BECOME-SUCCESS-rpipmkrsrpaexapqlqlbosjbuxunjzqg; /usr/bin/python /tmp/ansible-tmp-1516975940.36-226939758799942/command.py'"'"' && sleep 0'

EDIT: Was watching the install folder to check for new files, nothing added in ~30 mins. I killed the installer and ran it again, but it got stuck at the same point. Still no changes to any files or folders in the whole frappe-bench folder.

I don’t think you did enough to Ubuntu before you started the install. It is a very good idea to run:

apt-get update
apt-get upgrade

See the post here about starting with Ubuntu:

In the case above, the instructions were for setting up a developer server, but you can just change the switch to --production.

I had similar trouble with an A2Hosting account and had to upgrade Ubuntu before anything would work properly.

Hope this helps.


We retried with a brand new VM, worked first time. Not sure what the problem was, I think we may have also had Puppet installed originally which could have been conflicting somewhere.