Dropbox warning

hi guys,
thank you for your support. am facing an error while updating and the error is as:-

frappe 10.1.1 has requirement dropbox==7.3.1, but you’ll have dropbox 9.1.0 which is incompatible.
requests 2.18.4 has requirement urllib3<1.23,>=1.21.1, but you’ll have urllib3 1.23 which is incompatible.

the dropbox backup works fine , how do I solve this.

hi guys kindly help am still facing this warning.

I also face the same warning, I just ignored it since my dropbox too is working fine.
But it would be great to get a way to resolve this


I fixed this like so:

  • From you bench directory (e.g. frappe-bench) activate virtual environment:

    source env/bin/activate
  • Check current dropbox version like so:

    pip show dropbox
  • Install newer frappe package:

    pip install -e apps/frappe/
  • Retry setting up requirements:

    bench setup requirements --python
  • Check dropbox version again, to verify that it has updated to 9.1.0.



Am trying to activate virtual environment but am getting below error

frappe@vultr:~/frappe-bench$ source venv/bin/activate
bash: venv/bin/activate: No such file or directory

how do I go about this?

kindly help.

I used this

source ./env/bin/activate

and worked

this solved my issue thank you only change first command to

source ./env/bin/activate

thank you @snv

@jycob Thanks, I have changed my answer accordingly.