Try ERPNext Buy Support Partners Foundation

Does ERPNext support Python 3.8?

hi i`m planing upgrede my server to version 12
does erpnext support python 3.8?

thanks.

I have python 3.8 default in my system. (Arch Linux)

It’s working as expected. Just some warning messages

To be specific

../apps/erpnext/erpnext/accounts/doctype/share_transfer/share_transfer.py:172: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  shareholders = [shareholder for shareholder in shareholders if self.get(shareholder) is not '']
1 Like

how fix this

The warning will only occur with version 12 due to this code:

This is due to changes in Python 3.8:

https://bugs.python.org/issue34850

https://adamj.eu/tech/2020/01/21/why-does-python-3-8-syntaxwarning-for-is-literal/

Since the same code is not running in version 13 or develop, the warning shouldn’t occur further.