ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Disable the item name as "unique" value

Hi,

New to this forum.
I’m currently import data into the item. We have many products with the same name.
Wondering how can I disable the item name’s “unique” setting?
I did it many times under customization, however, “unique” is always back after I clicked “update”.

Any suggestion would be appreciate.

There are two fields, one called name and one called item_name. Can you confirm that you’re working with item_name? Also, what version are you using?

I don’t see name, only item_name. My version is v13.11.1.
One thing I noticed is that when I disconnected the Naming with item_name, I can disable the unique value. However, the system still told me item_name needed to be unique.
Any suggestion?


Can you show a screenshot of your “Naming” section? If you set that to something like field:item_code, Update, and then try to uncheck unique, what happens?

Thank you for the suggestion. However, still got the same warning msg.
Here is my Naming section which I changed to item_code, instead of item_name.


After I made those changes, the list view became this like below picture.

Not sure why I can’t see the Name in the customization?

name is a different kind of field for ERPNext. Every document has one, and it’s not required to be visible on the Customize Form tool. It’s the unique key associated to the document, and it can be defined in a number of different ways.

Can you clarify where exactly you are getting the “Item Name must be unique” error? If you are able to uncheck the unique key and then push update on the Customize Form tool, it should be working. Perhaps try clearing your cash by clicking “refresh” from the user menu.

It happened when I tried to create a new item and using the name which the item is already existed. The reason I’m doing this is because I have multiple products with same name, but different brand or spec, and I need to create it separately.

Somehow I think I messed up the setting causing this issue. When I dropped and reinstalled the site from scratch. The issue has been fixed. @peterg Thank you so much for helping!

1 Like

I have a similar issue, but with duplicating Tasks. When I try to save duplicate tasks it says that the Subject field must be unique and the Unique option for this field is turned off. Is there a way to make a forced change of this in frappe? Everything else works fine.