Try ERPNext Buy Support Partners Foundation Foundation Members

Developer Mode not shown

I have changed my site config setting to developer_mode:1 and also reload cache but no solution, really in dire need of help!

setup

please make sure you logged in as administrator.

Yes I did do that right now I am thinking to just migrate my server because so fed up.

I found that i could enable developer mode in a new instance but not so for an old instance even though i followed the same process. Seems weird.

1 Like

i think you should make sure that you use the right site from Current_site file and make migrate and build
if you do so, i think you will have it in developer mode

Tried all that, didn’t work. I have just one active site.

in this situation you should got to

Bench_name/apps/frappe/frappe/core/doctype/doctype/doctype.py

you will find function to check developer mode called

check_developer_mode

run the project and debug it to know what is going on

Well developer mode is enabled but for some reason my administrator account is not able to see it, Also if i disable certain cards in the dashboard and then enable them they might not come up so i am assuming maybe thats why I cant see the developer mode module.

I’m facing the same issue and i am assuming this only affects existing instances with data as new instances that i set up did not have the same issue.

Well in my case I didnt have to make a new instance for it to be fixed but the Administrator account still face this problems.

In my case I always need to clear the cache several times to be able to see the developer mode after I activate it. Inside erpnext use combination key ctrl + shift + r

I enable developer mode with the command: bench --site sitename set-config developer_mode 1

1 Like

Tried this… didn’t work for me.

Hm, that is weird.

In this case I can only think wether or not you can tell the developer mode is on ? Because erpnext will not tell you it’s on … there are only specific options and settings which become available.

You can tell if developer mode is on in V12 as a new module called Developer is added to desk from which you can access email queue, advanced doctype customization and others. You can access email queue through search without developer mode being on but that’s about all you can do if developer mode is off.

Yeah, sure, that as well.

So after you enable developer mode, do you see the setting appearing in the site_config.json file ?

Yes. It clearly shows “developer_mode”: 1,

Changing developer mode did worked but it would not reflect on my Administrator account when i made a new user who I then assigned as system admin, if logged in as that new system admin I would be able to see the developer portal that is what I did to utilize the mode.
When logged in to administrator account I could always use the awesome bar to find the modules that would be in developer mode.