Developer mode =1 in FC

I want to set developer mode on FC desk to 1 and it gives an error

We don’t support developer mode on Frappe Cloud. We also don’t recommend running any other production server in developer mode.

What is it that you want to achieve by enabling developer mode?

I want only to customize scripts of DocType on my account of ERPNext hosted on FC. What is my steps to be allowed to do that and what is the role of GitHub. That is because I have tried some scripts and they not worked at all even they do not give any error message .

As I see from Frappeframework doc , they said I must enable developer mode to 1

1 Like

If that is not suitable or allowed on FC , they do not explained that on frappeframework doc

Developer mode is needed for developing your own custom application. You should do this on your development machine (probably your laptop/desktop).

Once you have developed the application, you can deploy it on a production server (Developer mode is not needed for this)

Also, a lot of the customizations can be done on a production server (without Developer mode). Please see https://docs.erpnext.com/docs/user/manual/en/customize-erpnext

1 Like

you mean if I have installed bench of FC on my local Ubuntu server only I can enable Developer mode ? … Is it correct

Yes you can enable Developer Mode on your local bench setup.

I have my own machine now . I will try , thank you

Just out of interest. Will this not ever work?

@AdityaHase can probably confirm this. But it looks like that certain keys are purposely restricted on the backend for system integrity purpose.

So how can we enable the developer mode in FC?

Kind Regards