Try ERPNext Buy Support Partners Foundation

Department permission

Hey everyone… If there is two departments in the company that both makes purchase orders… Is there a way to make every department see its own purchase orders only without seeing the orders that the other department did?

User Permission will solve this:

https://docs.erpnext.com/docs/user/manual/en/setting-up/users-and-permissions

The point that i am asking about needs more demonstration… I mean if purchase department and production department are making purchase orders… I want the people in production department to see the orders that they made only… So how can i do that in user permissions?

First, you may need to Add the Department Field to the Purchase Order DocType using Customization -> Custom Fields -> New -> Document: Purchase Order, Label: Department , Insert After: Series, Field Type: Link, Options: Department, Is Mandatory Field: Check, In List View: Check, In Standard Field: Check

Note: fieldname: department is autogenerated

We can continue after this to keep this short

Okay i can manage to do that… What do i do after adding the department field to the document?!!

User Permissions
Users > User Permissions
User: username@example.com
Allow: Department
For Value: userdepartment
Is Default: Checked
Advanced Control
Apply to All Document Types: Checked (will apply to all documents

  • if not Checked (you can choose the document)
    Applicable for: Purchase Order

Repeat for all Users, Permissions, and Documents.

Thanks alot for your help

1 Like

Just one question
How to make the field autogenerated???

Session Defaults

i created the department field and it is shown now in purchase order,but when i click on the field and it doesnt get the available departments so that i can choose one of them

Does your user have permission for Department Doctype?

i am logged as administrator

that is how it is created

Do you have Department entries?

Your Field Type is wrong. It should be Link and the Options should contain Department. (Review my first instruction on this.)

1 Like

yes i have departments on my system ,but they dont show up

1 Like

It works fine now… Thanks

1 Like