Default Email When Emailing Out

Hello
I have a general issue in the system as explained below , not sure if anyone has experienced the same and how did they resolve if they had.

When emailing student fees,sales invoices etc the default email does not get fetched from the master doc i.e Customers,Students etc, although it has been populated.

I assumed the controls where in the default email acccounts -

Also seems like the docs do not corresponde to the system -

ERPNext: v13.7.0 (version-13)

Frappe Framework: v13.7.0 (version-13)

anyone on the forum experience this , i have restarted services as well with same result.
system does not fetch the default email address on the customer contact set as primary when email invoices etc.

The option you’ve circled here as 6. has nothing to do with using the email address of Students or Customers. It changes how the sender of an out going email appears, either as your system user account to the email defined here.

1 Like

Hi peterg thanks for responding…
please explain “It changes how the sender of an out going email appears, either as your system user account to the email defined here” , I dont quit get you on this point.

BTW , I have been troubleshooting in my test system V13.16.1 and when I email a test customer by default the email address populates however on the student fees invoice the default email does not although it has been populated in the student email field on the master doctype. User defined as system user. So there is something small that I am missing in my setup …

Hey @msalim79 please use google translate or deepl to translate the following. Hope that helps

thanks wojosc , will go through these for a solution.

I’m a bit unclear about what you’re asking. Are you trying to set the default email address that you send emails FROM or the email address you send emails TO?

hi peterg
The default outgoing email account done and dusted no issues there.

Its when a user wants to email a sales invoice or student fees invoice the challenge comes in. In my test system when emailing to customer the default customer email populates however same system same user , when emailing a student fees the default email on the student does not populate.(see screen shots) not sure what I am missing.

SalesInvEmailToCust

I have another site(production) that uses education module and setup same as my test site yet the default email addresses on both the sales invoice and student fees do not populate. So I am definitely missing something in my setup … just cant put my finger on what though.

Okay, that’s what I thought. In that case, the “Always use Account’s Email Address as Sender” won’t help you. All those settings manage the address you send FROM.

Hmm…I’ve never seen that effect for Sales Invoices. I’m surprised to learn it happens there. I don’t see anything at first glance in the code to suggest how that works, but it’s definitely possible there’s something in the Sales Invoice doctype that’s making it work automatically. There’s no simple configuration setting to make that work for other doctypes, however.

I think its my week of weirdness , lol