Data Import Version 10

Data Import tool seems to have some problem after its been upgraded to version 10. I tried following doc types

Supplier- on updating some fields in supplier doc.type its giving error that “naming_series is a mandatory field”. However in buying settings supplies are set by supplier names not by naming series.

User- upon any change in user data error message “argument of type ‘NoneType’ is not iterable”

1 Like

Can you please create a github issue reporting the error?

Sure i will

Good Job Saeed.

this will help community to stable the product

Hi @usmansaeed

I have fixed the issue for the supplier but for user I am not able to replicate the issue.

hi @usmansaeed
Could you please send us the error log for the same (FOR THE CASE OF USER)

@ManasSolanki please find below the error. Please note that this error come when we are updating any existing user.

File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/data_import/”, line 358, in upload
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/data_import/”, line 204, in validate_naming
if “.#” in autoname or “hash” in autoname:
TypeError: argument of type ‘NoneType’ is not iterable

Same error here

If the user has spanish (es-MX) as language, not english…

The “Import Status” never pass of “In Progress”.

I’ve already tested changing language to en-US and it works fine.

1 Like

Can be solved adding “hash” or series. I did and successfully import Address.

1 Like