Data Import tools Error

As per the attached Template for item bulk upload its show me the error below and i don’t know the reason

Error for row (#21) “SERV-ITEM-00012-AREA I” : makevariantitem_code() takes exactly 3 arguments (2 given).

can any one assist me and let me know where i have make the mistake .

I cant give you exact help, but from the error it appears you are presenting two bits of info for the varian item code when ERPNext is expecting three.

Try creating a variant item manually. then export this doctype, then inspect and compare to your data import

i have done that ,and the exported one still same as the one i have created
at least if we can know the make item variant argument so i can make sure that they are exist in the excel sheet.

Hi @ShehataGhattas,
This is a bug. I have created a github issue for this. You can follow up this discussion there.

I have sent a pull request, you can import your data once this is merged.

That is grate, please Let me know when its done
Thanks alot again.

I’m pleased that a bug has been reported and hopefully can be fixed quickly for you

Dear,
I have seen the fixing point i have change it manually, but its took me to another one its requesting for the item code and i have make the stock setting the Item Naming By naming series

Error for row (#21) : {“message”: “Item Code is required”, “indicator”: “red”}

Hi @ShehataGhattas,
Is your file for data import in proper format?

Yes , i have export one from the existing variant to create another one with new details, but it show me that error , Check Below.

the exported file

the imported file

the error file

Hi @ShehataGhattas
Are you trying to import new item variant in the system or updating the already created?
If you want to update then please remove the “Do not update, but insert new records” check, it will work fine then.

HI @ManasSolanki,
I’m inserting new records, actually the update is working very fine, the problem is the inserting .

@ManasSolanki,
any update please i have so many variant item to be inserted, FYI, inserting the items using the normal way from the browser its working very fine which mean the issue in the importing functions.

and thanks again for your support.

BR//

Hi @ShehataGhattas,
Please add one column of item code as given below, it will work then.

HI @ManasSolanki,
its working Fine Now , is this must be done every time , or you are going to rectify this issue in the future, like the exported template will be OK in the future time.

BR//

Actually, this is a design related issue so I think it will take time some time to be rectified. I have created a GitHub issue, please do follow that to be updated.

Ok and thanks again for your support.