Data Import Tool - "Do not update, but insert new records" working?

I would expect that marking “Do not update, but insert new records” would result into just nothing if you export a template CoA with data and re-import the exact same unchanged file (because the import tool would just ignore all known records)

instead I get an error message for each single line saying:

Duplicate name Account [account name]

That looks to me as if that functionality (ignoring unchanged existing entries and only add new things) just wouldn’t work. Is that so or do I not get something here?

I try this in order to understand how the import tool actually works. I a real life attempt I would add new entries naturally

If I got it right, if you don’t have the key column filled-in, the rows will be imported as new records. (not 100% sure)

what’s the ‘key column’? I am ex- & importing Accounts right now. Searching for the term ‘key’ in the exported csv (using OpenOffice) doesn’t find anything

Downloading the template I chose: “export with data” method

@vrms name is the key column

Hi,

Use the “Download with data” button to see the current entries.
In the csv you will find instructions like this:

Notes:
Please do not change the template headings.
First data column must be blank.
If you are uploading new records, leave the “name” (ID) column blank.
If you are uploading new records, “Naming Series” becomes mandatory, if present.
Only mandatory fields are necessary for new records. You can delete non-mandatory columns if you wish.
For updating, you can update only selective columns.
You can only upload upto 5000 records in one go. (may be less in some cases)

This mini-help changes for each document type, indicating the “key” column. (In bold above)

clear about the name (ID) column and how to leave that blank for new entries.
Naturally when using a downloaded (with data) template this column is not empty for existing entries.
So that you get an error message as the above is not the desired behavior.
I guess you can get it working like this by deleting all existing entries before importing the file.
That’s more hassle though but seems to work

just to update this thread, this capability just worked fine for me as of this moment (I use ERP Next 7.1.23 and Frappe 7.1.24 on my facility). I was able to export a big chunk of data in “Do not update but insert new records” mode for the DocTypes as follows

  • Customer
  • Address
  • Department
  • Employee

Hi

The issue here is that when the “Do not update but insert new records” option is checked, you would not expect to get ‘Duplicate Name’ errors since the expectation is for existing records (duplicates) to be skipped anyway. Hope you get the point

Regards

@wale: you are right.

@wale, @vrms: it looks like the one of the latest releases will take care of this problem eventually as https://github.com/frappe/frappe/pull/2512 has been just submitted (in response to the official bug per https://github.com/frappe/erpnext/issues/7311)

I just uploaded the Address template multiple times to update some addresses. I did not put a check on “Do not update but insert new records”. But each time a new record was created, the old name with a 1, 2 or 3 added to the end of its name. I would expect if there was a change in one of the fields that field would be updated without a new address being added and if there were no changes nothing would change. Am I doing it wrong?