Try ERPNext Buy Support Partners Foundation

Data Import Starts but does not Finish

Hi all,

We are having an issue where we have a stock entry ready to import using the data import tool, all fields have the “green light” icon. When we click Start Import, the button goes disabled as if it’s working, but then nothing happens and the import does not resolve. The Start Import button does go back to enabled state after a few seconds, but the document stays in “Not Started” status. Any ideas?

Did you import CSV or XLS? - I have had cases where there are “phantom” cells thousands of rows/columns along that make the system think there is more data which is tries to work with unsuccessfully. Best to use CSV as it is easier to manage

I’m using a CSV with only 21 rows of data, and it’s worked just fine up until this point. I also tried re-downloading the file from our database to upload in, to double check that it’s not an issue with the file, and it still isn’t going anywhere.

OK - not sure why that’s happening. The only thing I can think of is that something that’s referenced in the CSV data is missing on the main system eg. An item that goes into a non-existing category could possibly cause this “hanging”

That’s a good thought, @trentmu – I just double checked that all the items in the CSV exist in our system, so it seems it’s not that. I wish it would at least throw me an error; I get nothing in the UI or in the console while it’s “processing”.

Check the browser’s JS console and see if there is any error traceback on clicking Start Import.

Some times, just reloading the page works.

@kennethsequeira Sorry Kenneth, no relevant errors coming up in the ERPNext UI or in the console; you can see the Start Import button is disabled after I’ve clicked it, but it reverts to “enabled” state after about 3 seconds and nothing actually happens.