ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Custom Script Not Working in V11


#1

Hello all

Is it me or is are custom scripts not working in V11? Currently on 11.1.6

Regards


Search Fields for Item Doctype
#2

Hello, I too noticed this disturbing behaviour after modifying a custom doc type and thereafter adding a custom field via the standard customise function.

I duplicated the custom doctype and the script that would not work on the enhanced doctype would work again.

This is quite unsettling


#3

In my case the doctype is a custom one that I created from scratch.

I am hoping some higher minds can help take a look at this


#4

So it looks like the issue is limited to custom doctypes


#5

Try duplicating your custom doctype and test the custom script on the fresh one


#6

Just tried it…No Luck


#7

Would you mind showing a snippet of your code and how you set it up?


#8

cur_frm.add_fetch(‘contract_template’,‘contract_terms’,‘contract_terms’)

I noticed my code doesn’t have the semi colon at the end as does the example


#9

Funny, this is the exam same code am trying to set up

Will remove the semi colon


#10

I am feeling your frustation…it took me some time before I figured out that the problem was the doctype


#11

very very funny indeed!


#12

No Joy

Did not work for me


#13

I’m sorry it didn’t work.

Since you are working of similar content, perhaps duplicate the following doc type (Contract)and add to it as you see fit

From the sounds of things, It has most of the detail you need to get started.

I did that and eventually it worked for me.

What I noticed is that you must not use the customise function but instead, apply all changes directly to the doc type


#14

What version of ERPNext are you on ?


#15

v11.0.3-beta.25


#16