Custom Naming Series disappears after update

Dear community,

I have updated frappe and erpnext to the latest version.

ERPNext: v8.0.38 (master)
Frappe Framework: v8.0.59 (master)

For the last couple of time that I updated, the naming series I created for some DocType such as Journal Entry, Sales Invoice and Purchase Invoice always disappear.

Anyone experience this too?

1 Like


No hosting customer has also reported this issue. After updating Naming Series, check if Property Setter record is created for it.

1 Like

Hi @umair

I apologise if I misunderstood your post or wasnt being clear.

Updating in my post is updating erpnext and frappe … wheneever I update erpnext or frappe, the custom naming series disappear.

Have a blessed Ramadhan

Even I have faced this issue a couple of times, I was wondering where did the naming series vanished.
I had defined custom naming series in Sales Invoice and one of my custom doctype which were not there after I ran bench update / bench migrate. I am on ERPNext: v8.0.33 (master)

Is this a personal installation?

bench migrate should do the trick. Maybe. :smiley:

@littlehera yup … but still the same …

Hi @mulyadi-agtechsg,

Are the customizations stored in a repository? Or is there a repository linked to your current project?

What we usually do is we run export-fixtures so that naming series, custom scripts, print formats are also stored in the custom app repository and can be pushed to the rep. We pull the changes from the repository, and run bench migrate. If you have a database backup with the recent changes, you can also try restoring the db.

1 Like

Hi @littlehera

There is a repo linked to the project. However, the ones missing are the Sales Invoice, Purchase Invoice and Journal Entry naming series.

Can one of the developers who has naming series working run export-fixtures and then push the updated file to your repository? Afterwards, you can update your instance and then run bench migrate.

Hi @umair

I checked that Property Setter is created.

However, after I did a bench migrate, the values went missing.

Please advise.