Try ERPNext Buy Support Partners Foundation

Custom module is not appearing in user's allowed module

hi guys

i have created custom app but that is not appearing in user’s allowed module

thanks and regard
Mohd. ELiyas

1 Like

Hello, i have the same error, can you find the problem?

Is into your YourModule/config/desktop.ini did you put somthing like
def get_data():
return
[
{
“module_name”: “YourModule”,
"category": “Modules”,
“label”: _(“YourModule”),
"type": “module”,
“description”: “YourMoiduleDesc”,

},
]

?

Yes, my Module Configuration:

from __future__ import unicode_literals
from frappe import _

def get_data():
        return [
                {
                        "module_name": "Module_Name",
                        "category": "Modules",
                        "color": "blue",
                        "icon": "octicon octicon-file-directory",
                        "type": "module",
                        "label": _("Module_Name")
                }
        ]

Did you add your app to your site with bench command?

yes, after i edit the desktop.py file. I also Try these bench commands, but without effect
bench migrate
bench clear chache

image

Reload from Setting menu ?

Do you find any of Library own made doctype in global search ?

I made a self training with library module, and I see the module into users Setting. (you can find some good sample here https://github.com/frappe/library_management/pulls)
When I check the code it depends on Module List Doctype, nothing seems to limit choice except what I already told you.
Did you investigate on local environment what happend by debugging/trace Frappe code ?

You’re on the develop branch The suggested steps are for v12.

To create a module page go to Desk Page in your instance and create a new page there:

1 Like

Thanks thats works!