Created doctype is missing, custom is checked and erpnext v10 is in production mode

Hello
ERPNext is in production mode and the option ‘custom’ is checked i’m not able to uncheck that, when I create new doctype; doctype is created in the doctype list but I’m not able to see the created form
I select HR module.
erp version is 10.^
please help me

Hey @zia - most of the time, this is because you (or the administrator) have not assigned the correct permissions, which are towards the bottom of the doctype page.
Try logging in as the administrator and seeing if you can find it that way, then add the permissions.

Cover in not quite enough detail here, but it should get you started.

1 Like

Thank you tmatteson for replying me

actually my role is system manager in ERP it doesn’t mean administrator?
and I have created a role as well for this doctype and given read, write, create and delete permissions
please let me know if I’m wrong

thanks again

If you still don’t see it after adding the permissions, try running bench migrate, then look again

1 Like

Dear @tmatteson I’m using ERPNext which is in production mode how can I access bench command?
if its possible please let me know.
there is no way to switch to development mode back right?
its 3 days I’m stacked in this. Created doctype shows in the list of doctype but its related form is not showing.

there is a link for the screen shots if you could check.

Thanks again

Since you created a new role for it, did you assign that role to your user ?

Go to User DocType and select your user from the list. Next check the roles assigned to your user and see if the role you created with the custom doctype is checked for you.

If you don’t see the role that you created in the Roles list in User. Go to Role DocType and check if the role in question is enabled or not ? If not, then enable it and assign it to yourself.

Thanks dear @Zlash65 I got
now the form displays, I have created a doctype named ‘Books’ but when I create new book when save it, the book name does not show a code comes instead of name.
could you please help me
Thank you

In your doctype that you created, below the table for fields, there’ll be a section called “Naming”.
In that there’s a field Autoname which needs to be set. If its blank, then a hash is generated and treated as name which is what is happening with you.

Set Autoname as field:the_fieldname_you_want

Thank you @Zlash65 it helped me a lot