Create domain on vps

Hi
I arrange to get VPS to install Erpnext on it and the technician asked me if I need docker or ubuntu and I didn’t know any own is more durable for me since I need to create a domain as erp.com.eg to access Erpnext from VPS
kindly advice

For getting started, go ahead and get either a Ubuntu v20.04 or Debian v10 VPS server. Get the instruction for how to access the new server from a SSH client like Putty.

Next get your URL (erp.com.eg) from the service provider and have them set the DNS pointers to the IP Address of your new VPS server.

Finally use the following instruction to install the ERPNext application, the associated URL name, and the free SSL certificate:

And before you ask, yes, the above instructions should also work for Ubuntu servers. I personally use Debian because earlier this year Ubuntu was not as stable with ERPNext installs and Debian v10 always just seemed to work.

“Docker” is another way to setup ERPNext servers but it is not yet easy enough for new users to attempt.

Hope this helps.

BKM

1 Like

People have different opinions on this, but I would argue that the docker installation is both easier and more durable than any manual install.

Installation is just a few steps for most users. Instructions can be found here:

1 Like

Try this post:-

https://discuss.erpnext.com/t/installation-of-erpnext-13-through-easy-install-script-on-amazon-ec2-instance-and-setup-lets-encrypt-certificate/82141

1 Like

Many thanks for your replays I will try the first solution and will write down my feedback

Did it solve your problem?

i get this errors

The repository ‘http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4/ubuntu focal Release’ does not have a Release file

The repository ‘http://old-releases.ubuntu.com/ubuntu focal-security Release’ does not have a Release file

this all what i get

Err:1 http://nova.clouold-releases.ubuntu.com/ubuntu focal InRelease
Could not resolve ‘nova.clouold-releases.ubuntu.com
Err:2 http://nova.clouold-releases.ubuntu.com/ubuntu focal-updates InRelease
Could not resolve ‘nova.clouold-releases.ubuntu.com
Err:3 http://nova.clouold-releases.ubuntu.com/ubuntu focal-backports InRelease
Could not resolve ‘nova.clouold-releases.ubuntu.com
Ign:4 http://www.deb-multimedia.org jessie InRelease
Hit:5 http://ppa.launchpad.net/ubuntudde-dev/stable/ubuntu focal InRelease
Ign:6 http://www.deb-multimedia.org jessie Release
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:10 http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4/ubuntu focal InRelease
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Err:14 http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4/ubuntu focal Release
404 Not Found [IP: 172.67.148.71 80]
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Ign:15 http://old-releases.ubuntu.com/ubuntu focal-security InRelease
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Ign:7 http://www.deb-multimedia.org jessie/main amd64 Packages
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Err:16 http://old-releases.ubuntu.com/ubuntu focal-security Release
404 Not Found [IP: 91.189.91.123 80]
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Err:7 http://www.deb-multimedia.org jessie/main amd64 Packages
404 Not Found [IP: 91.121.146.196 80]
Ign:8 http://www.deb-multimedia.org jessie/main all Packages
Ign:9 http://www.deb-multimedia.org jessie/main Translation-en
Ign:11 http://www.deb-multimedia.org jessie/main Translation-en_US
Ign:12 http://www.deb-multimedia.org jessie/main all c-n-f Metadata
Ign:13 http://www.deb-multimedia.org jessie/main amd64 c-n-f Metadata
Reading package lists… Done
E: The repository ‘http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4/ubuntu focal Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘http://old-releases.ubuntu.com/ubuntu focal-security Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Traceback (most recent call last):
File “install.py”, line 495, in
install_prerequisites()
File “install.py”, line 151, in install_prerequisites
run_os_command({
File “install.py”, line 143, in run_os_command
returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.8/subprocess.py”, line 364, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo apt-get update’ returned non-zero exit status 100.

Easy install script has some problems right now.
Source: I am facing this from last two weeks in installation of ERPnext on Ubuntu 20