ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Cost of good sold used when i receive items

Hello …
I MAKE a Purchase order and i receive the product and every thing is great The item quantity is 1 and the price is 4$ but when i check my general ledger i see the account of cost of good sold moved in credit amount 0.0010

So why the cost of good sold used her??

Check the configurations in company doctype. Looks like round off account is set to cost off goods sold account

Thanks for your reply…
BUT The round off account in my company is not cost of good sold account…
When does next make round off in stock journal ?

Check currency precision in settings and your currency doctype

I check it but there is nothing wrong because the same setting i made another purchase order and every thing going will …
No entry happen like in the previous purchase order

It is because of item’s expense account is set cost of Goods Sold in item master, that’s why system is taking rounding off impact to such account.

System is calculating valuation rate on your goods receipt document and may be because of such calculation there is rounding difference occur.

Do you have negative stock enabled? And did this purchase receipt make stick balance go positive from previously negative stock?

NO it is positive .
How i can enable negative stock ?

I check it But the expense account is empty field .so this is way it use cost of goods sold by default ?

if its not at Item Master Level then check in Company Master >> Accounts Settings

Yes because its set in company defaults as CGS account

Hi @yara,

I agree that because you have not sold anything (yet) then ‘COGS’ should not be posted to.

So far, I have not seen any explanation for this. Your settings appear correct.

  • Can you explain your steps? First, you create and submit your Purchase Order. Next, you are creating and submitting a ‘Purchase Receipt’? Are you creating a ‘Purchase Invoice’?

  • What version of ERPNext are you using?

  • Does this happen for all Items, or only certain ones?

I am actually experiencing this issue on Version 13 latest release.

Really strange unexplainable behaviour

And it happens somewhat randomly

1 Like

Hi @brian_pond
FIRST I made the purchase order then i submit it after that i created Purchase Receipt and submit it this is when the cost of goods sold used ND NO i did not make a purchase invoice .
I AM working on v13.4.0 version
No this happens only on this items although i had used it before in purchase and selling and nothing like this happens .

Hi @yara
We faced the same problem, did you find any solution or clarification for it?
Thanks

Hi
not till now we do not know the reason or when this happend but would you please tell me the scenario that lead to this result

Same as you, please find below

did you have a standard price for this item?
or a price list selected for it?
and one more question is there a previous po for this item ?

Finally, I solved it
In System Settings=>Date and Number Format=>Currency Precision
In my case, it was 4 when I changed it to 3 the problem has been solved.