Try ERPNext Buy Support Partners Foundation

Compiling Python Files... *** Error compiling '../apps/erpnext/erpnext/education/doctype/guardian/guardian.py'... File "../apps/erpnext/erpnext/education/doctype/guardian/guardian.py", line 40 print guardian_as_user

erpnext@ubuntu:~/erpnext/frappe-bench$ bench update
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: `pip install frappe-bench`

Backing up sites...
$ git pull  upstream version-12
From https://github.com/frappe/frappe
 * branch                version-12 -> FETCH_HEAD
Already up to date.
$ find . -name "*.pyc" -delete
$ git pull  upstream v10.x.x
From https://github.com/frappe/erpnext
 * branch            v10.x.x    -> FETCH_HEAD
Already up to date.
$ find . -name "*.pyc" -delete
Installing applications...
$ /home/erpnext/erpnext/frappe-bench/env/bin/pip install -q -U pip

Installing frappe
$ /home/erpnext/erpnext/frappe-bench/env/bin/pip install -q -U -e /home/erpnext/erpnext/frappe-bench/apps/frappe 
ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

erpnext 10.1.81 requires googlemaps==3.0.2, but you'll have googlemaps 3.1.1 which is incompatible.
$ yarn install
yarn install v1.22.5
[1/4] Resolving packages...
success Already up-to-date.
Done in 0.53s.

Installing erpnext
$ /home/erpnext/erpnext/frappe-bench/env/bin/pip install -q -U -e /home/erpnext/erpnext/frappe-bench/apps/erpnext 
ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

frappe 12.10.2 requires googlemaps==3.1.1, but you'll have googlemaps 3.0.2 which is incompatible.
Updating node packages...

Installing node dependencies for frappe
$ yarn install
yarn install v1.22.5
[1/4] Resolving packages...
success Already up-to-date.
Done in 0.70s.
Patching sites...
Migrating erpv10
Updating DocTypes for frappe        : [========================================]
Compiling Python Files...
*** Error compiling '../apps/erpnext/erpnext/education/doctype/guardian/guardian.py'...
  File "../apps/erpnext/erpnext/education/doctype/guardian/guardian.py", line 40
    print guardian_as_user
                         ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print(guardian_as_user)?

*** Error compiling '../apps/erpnext/erpnext/healthcare/doctype/healthcare_settings/healthcare_settings.py'...
Sorry: TabError: inconsistent use of tabs and spaces in indentation (healthcare_settings.py, line 28)
*** Error compiling '../apps/erpnext/erpnext/hr/doctype/payroll_entry/test_payroll_entry.py'...
  File "../apps/erpnext/erpnext/hr/doctype/payroll_entry/test_payroll_entry.py", line 170
    new_year = dt + relativedelta(month=01, day=01, year=dt.year)
                                         ^
SyntaxError: invalid token

*** Error compiling '../apps/erpnext/erpnext/patches/v4_0/validate_v3_patch.py'...
  File "../apps/erpnext/erpnext/patches/v4_0/validate_v3_patch.py", line 11
    raise Exception, "site not ready to migrate to version 4"
                   ^
SyntaxError: invalid syntax

*** Error compiling '../apps/erpnext/erpnext/setup/utils.py'...
  File "../apps/erpnext/erpnext/setup/utils.py", line 131
    except frappe.DuplicateEntryError, e:
                                     ^
SyntaxError: invalid syntax

$ bench build
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: `pip install frappe-bench`

yarn run v1.22.5
$ FRAPPE_ENV=production node rollup/build.js
Production mode
✔ Built js/moment-bundle.min.js
✔ Built js/libs.min.js

Building frappe assets...

✔ Built js/checkout.min.js
✔ Built js/dialog.min.js
✔ Built js/modules.min.js
✔ Built js/social.min.js
✔ Built js/web_form.min.js
✔ Built js/list.min.js
✔ Built js/chat.js
✔ Built frappe/css/email.css
✔ Built js/desk.min.js
✔ Built js/barcode_scanner.min.js
✔ Built js/bootstrap-4-web.min.js
Browserslist: caniuse-lite is outdated. Please run next command `yarn upgrade caniuse-lite browserslist`
✔ Built css/frappe-rtl.css
✔ Built css/printview.css
✔ Built js/frappe-recorder.min.js
✔ Built js/frappe-web.min.js
✔ Built js/control.min.js
✔ Built css/module.min.css
✔ Built css/form.min.css
✔ Built css/list.min.css
✔ Built css/report.min.css
✔ Built js/form.min.js
✔ Built css/frappe-chat-web.css
✔ Built css/web_form.css
✔ Built css/desk.min.css
✔ Built js/report.min.js
✔ Built js/data_import_tools.min.js
✔ Built css/frappe-web-b4.css
✨  Done in 51.824s

Building erpnext assets...

✔ Built js/erpnext-web.min.js
✔ Built css/erpnext.css
✔ Built js/item-dashboard.min.js
✔ Built js/erpnext.min.js
✨  Done in 2.364s
Done in 55.70s.
________________________________________________________________________________
Bench: Deployment tool for Frappe and Frappe Applications (https://frappe.io/bench).
Open source depends on your contributions, so do give back by submitting bug reports, patches and fixes and be a part of the community :)