ERPNext Conference 2019* ERPNext.com Blog

Can't send email other than Welcome (new user) email


#1

Hello community,

I set email domain (gmail) and default sending account (gmail).
i know that outgoing account is working, it’s successfully sending email when i create new user.
the problem is I can’t send email for quotation, sales order etc.
in Communication List, it’s stated sent, but the mail never arrived. i check it in gmail, nothing on sent email, and nothing on inbox from erpnext.

can someone point out what should i check?

Thank you


#2

These emails sometime end up in the Spam folder. Please check Spam folder in the receiver’s inbox.


#3

Have you enabled scheduler for that site? bench --site site_name enable-scheduler

Unlike the welcome email, others are sent in the background.

You can also access the Email Queue list to check the backlog


#4

Thank you, i checked on the spam list, it’s empty


#5

Thank you @RWEMA_Aimable for the response. A few days ago i already did enable-scheduler. a few minutes ago i did enable-scheduler again (yesterday i rebooted the server and forgot to enable the scheduler again). but, no email sent.

i open the Email Queue List (for the first time, i’m very new to erpnext), and saw 20 not sent email and 1 sent email (welcome email).

open 1 email and click send now, and then the email sent in a minute. now (13 minutes after click send now) the rest of the email still not being sent.

how i check the scheduler working properly?

Thank you


#6

try bench --site site_name doctor to check if scheduler is properly enabled. If it is, you should not need to reenable every time you reboot. Also when you click Send Now, the email should be sent instantly.


#7

Thank you for your response, i tried these:

bench --site mysite enable-scheduler
result: enabled for mysite

and then
bench --site mysite doctor

result: scheduler paused for mysite
scheduler inactive for mysite
worker online: 3

why the scheduler won’t be active? no error message thrown when i executed enable-scheduler

Thank you


#8

I have the same issue here. Even after enabling scheduler for all sites, it still returns as paused & inactive.

HEY! USE SCREEN [frappe@erpserver frappe-bench]$ bench --site all enable-scheduler
Enabled for *********
Enabled for *********
HEY! USE SCREEN [frappe@erpserver frappe-bench]$ bench doctor
-----Checking scheduler status-----
Scheduler paused for *********
Scheduler inactive for *********
Workers online: 6
----- Jobs-----

#9

@a_vooc @lams
It might have been paused while updating bench. You can undo it by going to sites/common_site_config.json. As shown in the image, pause_scheduler must be 0 or totally absent in the file. Just make it 0 if its showing 1 and save.
image


#10

Amazing!! This fixed my issue. Although I removed the pause_scheduler line from both the site folder of the affected erpnext website and from the sites/common_site_config.json


#11

Thanks a lot @Nick !!! It is sending emails now…