Can't remove app

Hi,

  1. I created an app with bench new-app appname.
  2. installed it to a site with bench --site sitename install-app appname
  3. no longer used this app so unsintalled it with bench --site sitename uninstall-app appname and finally got this message:
Uninstalled App appname from Site sitename
  1. then tried to remove the app with bench remove-app appname but got this message:
Cannot remove, app is installed on site: sitename
  1. tried bench remove-from-installed-apps appname still can’t delete the app.
  2. tried bench remove-app appname again still got the same Cannot remove message.

This is not the only app and the first time happened lately.
Now my version is this:
erpnext 12.13.0
frappe 12.11.0
But it happened I this since 2-3 minor versions before.

Is there any change in the bench to remove app?
Did I do anything wrong?
Thanks

Try bench clear-cache or drop the site?

Had done clear-cache but still the same.
Can’t drop-site because it is a live site.

What I did then was removing it manually.

The same problem I am facing with the Pitu app…