ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Can't find doctype py files

Hey, complete newbe here.

Want to add a custom script, but can’t find the “.py” files for the doctypes I create. The “Custom?” checkbox is left checked and greyed out.
I am logged in as an administrator and I set the site developer_mode config to 1.

Basicaly I want to create a table as a child (“Reciepe”) of a doctype (“Dishes”). The table should have a data field ( quantity ) and a select field ( raw_material ).
I want to populate the raw_material with var_name field from anothe doctype (“Raw Materials”, which also has their prices, thus allowing me to calculate the cost of each dish).

1 Like

Hello,

The Custom? should be unchecked. After setting your developer_mode to 1, you have to clear the cache using bench clear-cache.

Regards,

Ivan

did:

~/frappe-bench$ bench --site site1.local set-config developer_mode 1
~/frappe-bench$ bench clear-cache

still:


any thoghts?

Hello,

Did you restart your bench?

Regards,

Ivan

not before.
now I did:
~/frappe-bench$ bench --site site1.local set-config developer_mode 1
~/frappe-bench$ bench clear-cache
~/frappe-bench$ bench restrt
still the same…

1 Like

Hello,

Try to open your site with Incognito / private browsing mode and check if you can uncheck the Custom?

Regards,

Ivan

tried private browsing, still no go… :unamused:

ther’s this which suggests:
"You also will need to enable the Developer icon in your desktop settings:
Desk -> User dropdown list -> Set Desktop Icons -> check "Developer""
can you tell me if this has anything to do with what I’m trying to achieve?

Hello,

Have you taken a look into your site_config.json?

Try to check whether your developer_mode on site_config.json is the same with mine. It should be a number (not wrapped in quotes).

Regards,

Ivan

1 Like

sadly…
it’s the sam as yours…
image
I have decided to try and reinstall the server.

tried reinstalling, this time did not revert to production at the end of the installation
(left out: sudo bench setup production %user )
still no such success… :-\

I don’t know how or why, but eventually, after the I-don’t-know-how-many-th time I cleared cache, and restarted the bench - it worked!! :grinning:
thank you for the support!

1 Like

[SOLVED] I had similar problem…
I added manually developer_mode

An then I run this commands:

Reload page, and it’s done.

“Custom?” checkbox can be disabled.

1 Like