Can't access erpnext installation with domain name

I’ve done a docker based setup as described in githup frappe_docker

I can access the site via http://127.0.0.1:8080 or any other ip address used by the host successfully.

But when i try to access via the hosts full domain name ex. erp.myserver.com i get in troubles.
The system redirects to https and get an SSL error (which is expected since no ssl is setup)

Why is there a automatic switch to SSL when accessing with a full domain name?
How can i stop this and keep http?
Any other hints?

don’t use traefik. it is managing the redirect and certificates.

instead of publishing port 8080 of container to 8080 of host, publish it to port 80 of host

Thanks for the answer.
I’m not using traefik.
Setup is based on

docker compose -f compose.yaml -f overrides/compose.redis.yaml -f overrides/compose.erpnext.yaml -f overrides/compose.mariadb.yaml -f overrides/compose.noproxy.yaml config > ~/gitops/docker-compose.yml

Nginx in the docker setup uses 8080 by default and as configured in the override/compose.noproxy.yaml it exposes this to the host.

Hello again

Anyone can help on this issue?

not really. I tried.

play with docker seems to be working. Play with Docker

check this yml file which is used for PWD. https://raw.githubusercontent.com/frappe/frappe_docker/main/pwd.yml it uses environment variable for frontend container that specifies the default site name for bench (FRAPPE_SITE_NAME_HEADER: frontend). it’s not using ssl

Play with docker let me not reproduce the issue situation.

I don’t want to set FRAPPE_SITE_NAME_HEADER since it should be possible to use the multiside setup.

After setting up the docker environment I create multiple sites:

bench new-site mytest-erp.lan
...
bench new-site mytest-pg.lan
...
bench new-site erpserver.mytest.com
...

I add the entries to my host file

192.168.0.10    mytest-erp.lan
192.168.0.10    mytest-pg.lan
192.168.0.10    erpserver.mytest.com

I use my browser and navigate to
http://mytest-erp.lan:8080 → ok
http://mytest-pg.lan:8080 → ok
http://erpserver.mytest.com:8080 → reroutes to http://erpserver.mytest.com:8080 and fails with ERR_SSL_PROTOCOL_ERROR

Any ideas?

redirect is done using traefik and labels.

more in traefik docs:

try disabling this traefik feature.

I found the issue.
I 've fallen into the browsers trap of HSTS capabilities of forcing sides to be https :frowning:

Took me several days, never stop learning.

Thanks again for your patience.