Try ERPNext Buy Support Partners Foundation

Cannot update ERPNext

Hi everyone,

I am a new ERPNext user. I have downloaded and installed the virtual machine from the erpnext homepage.
erpnext: 12.6.0
frappe: 12.4.1

I would like to update to the newest version but it seems to fail every time:
I tried
bench update gives me the following strange error:

image

then I have tried sudo bench update which gave me the following error:

Remote: Compressing objects: 100% (46441/46441), done.
Error: inflate: data stream error (invalid distance too far back)
Fatal: pack has bad object at offset 3316259: inflate returned -3
Fatal: index-pack failed
Backing up sites..
INFO: bench.app:pulling frappe
$ git pull upstream version-12 

After both commands I am able to access the erpnext desk without any errors. erpnext is still 12.6.0 and frappe 12.4.1
I would be very grateful if you could help me to solve my update problems :slight_smile:

Was the first attempt at updating and without any customization of code? Has bench update --reset been tried?

Thank you very much for your reply!
I have not customized any code.
bench update --reset did not solve the problem:

image

image

image

image

image

After that it is still stuck at version 12.6.0 (ERPNext) and 12.4.1 (Frappe)

Try with git fetch --all for each repo.
It will take a while to unshallow each repo (be careful because will download a lot of data -> 2/3 Gb)
After the unshallow do bench switch-to-branch version-12 erpnext frappe (the latest) or to each repo git checkout version-12.

Hi @fromthestone,
I have tried to do git fetch --all but my command is wrong. Where do I find each repo?
Sorry for my stupid question, I am a newbie and could not find more information with the forum search function.

Hi,

I think I found out how to do git fech --all for each repo, but I receive an error when I do that:

Any idea what I can do?

What does: git status return?

Try this solution:
https://stackoverflow.com/questions/41741683/git-error-inflate-data-stream-error-unknown-compression-method

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.