I often made mistake clicking Cancel button after reopening a submitted doc. This is caused by the common UX in many apps (if you don’t want to save the doc after opening it, then click Cancel).
So I propose to change the label of Cancel button to Void.
Afterall, it is what it does… void a document.
And it is more proper term than cancelling a submmitted document.
For v12 and v13.