Can not find ERPNext modules

I am a newbie to ERPNext, I just finished installing ERPNext, logged as admin to localhost:8001, but I cannot find the modules. Please help me.


You’ve probably installed Frappe but not ERPNext. ERPNext is not installed to a Frappe site by default after its creation so you have to ensure it’s done.

Try this:

cd frappe-bench
bench --site <site_name> install-app erpnext

Login / refresh and check again.

All the best!

1 Like

Thanks for your reply, I tried “bench --site <site_name> install-app erpnext” but got this message: Could not find app “erpnext”.


bench get-app erpnext

and then

bench --site <site_name> install-app erpnext

1 Like

Thank you for your reply, I tried:
bench get-app erpnext
But got this error:

bench.utils.CommandFailedError: git clone  --depth 1 --origin upstream

can you tell me why?

This is the whole output: app erpnext
INFO:bench.utils:git clone --depth 1 --origin upstream
Cloning into ‘erpnext’…
remote: Enumerating objects: 5561, done.
remote: Counting objects: 100% (5561/5561), done.
remote: Compressing objects: 100% (4347/4347), done.
error: RPC failed; curl 56 GnuTLS recv error (-54): Error in the pull function.
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/opt/erpnext/bench-repo1/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/opt/erpnext/bench-repo1/bench/commands/”, line 40, in get_app
get_app(git_url, branch=branch)
File “/opt/erpnext/bench-repo1/bench/”, line 124, in get_app
cwd=os.path.join(bench_path, ‘apps’))
File “/opt/erpnext/bench-repo1/bench/”, line 159, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git clone --depth 1 --origin upstream

Can you tell me what the problem is please?



Did you use the the Easy Install method for your setup?

Not sure about the error but EOF errors are usually related to incompletely downloaded scripts. Try this:

cd ~/frappe-bench/apps
sudo rm -r erpnext

cd ~/frappe-bench
bench get-app erpnext
bench --site <site_name> install-app erpnext
1 Like

bench --site [] install-app erpnext


Old thread but you will need to provide full valid URL of ERPNext module.

bench get-app erpnext

Refer to Can not find ERPNext modules