ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

[bug] "You do not have enough permissions to access this resource"


#1

I have an item template and when I want to create a variant I get an

Not permitted. You do not have enough permissions to access this resource. Please contact your manager to get access.

still the variant is being created. The user who get’s this is an “Item Manager”
should I post this as an issue on github?


#2

Hi @vrms

I have same this error, you have solution? pls share thanks


#3

sorry, did not follow up on this specific issue which occured at some point testing stuff.
But, as you seem to run into the same problem 1 year later, there must be others with similar issues and hopefully a solution somewhere?


#4

the similar issue on creating item variant.
You do not have enough permissions to access this resource. Please contact your manager to get access.


#5

From the last update ERPNext: v10.1.72 (master) / Frappe Framework: v10.1.64 (master)
when i Make variant from a template I get:

You do not have enough permissions to access this resource. Please contact your manager to get access.


#6

I’m getting the same error after updating and I was logged in as Administrator. It was working fine before doing a bench update. I’ve tried to reset the permissions but that doesn’t seem to help.


#7

I noticed the same problem.


#8

I’m also running into this, latest V10.


#9

Also have this issue. Running on a hosted version. Would appreciate a rapid solution.


Cannot Create Variants - not enough permissions to access resource
#10

we have the same problem here :egypt: we just upgraded yesterday , any solutions please ??


#11

@AzizPlast it seems you have accidentally flagged one of the posts in this topic .

can you kindly unflag it if my assupmption (that this was done by accident) is true?


#12

it is weird. Even though I brought this up I forgot about it completely. and have managed to create Variants for a while. Just checking again I get the same error on v10.1.73.

As v11 is around the corner I believe and this is not too pressing for me right now I’ll leave it for the moment. @AzizPlast @cpurbaugh, … I’d post an issue on github for this


Cannot Create Variants - not enough permissions to access resource
#13

with v10.1.64 , was that happening too ??


#14

Up to v10.1.70 I was able to make variants.


#15

Same Here !


#16

This has been fixed.


#17

nice !

Just for my understanding … I’ve noted the fix was merged into the hotfix branch (which is the standard procedure I think). Before that then actually takes effect on a productions site the hotfix bracnh now still needs to be merged into master, right?


#18

I do not think this has been corrected in the master branch as yet.


Bugfixes - procedure = PR > hotfix > master?
#19

It does not appear to be implemented yet. When can we expect this to be implemented and working in the hosted solution?


#20

Hi. Any update on when we can see a fix for this? We need to create item variants ASAP.


"You do not have enough permissions to access this resource" when creating item variant