Bug in Profit and Loss report?

Profit and Lost report problem. Figures is copied to all the months in 2016. I think the right values should be zeros in Feb 2016 etc. because there is no income and expense yet happend. Is this intentional? or a bug?

@ccfiel, I believe that Balance Sheet is a cumulative report, so, this is the balance of the last month!

But I’m not sure if it is the right behavior.

1 Like

@max_morais_dmm yes you are correct in balance sheet but the profit and loss should be per month basis. In feb 2016 etc. should have zero values because there no Income and Expense yet happend. Do I make sense? :smile:

@ccfiel, it’s paradoxal, the answer is maybe.

I can see what do you mean, but there in Brazil, balance sheet should be as this way, maybe @nabinhait, have some words about this.

1 Like

Not sure which is the right. But you have both options, in Profit and Loss Statement, it shows cumulative monthly balance but in Financial Analytics, it shows monthly.

1 Like

@anand @nabinhait Would it be useful if I submit a PR for Profit and Loss. I will put e checkbox “Year to Date” if check it will be cumulative if uncheck it will be month to month bases?

2 Likes

@ccfiel You are always welcome, please go ahead.

Even I was thinking to make the changes, it is more desirable in month to month basis.

@nabinhait I will to do this next week. :smile:

2 Likes

@ccfiel @max_morais_dmm

Made the changes https://github.com/frappe/erpnext/pull/4730. Now, user can choose as per their preference.

3 Likes

Hi,

In Profit and Loss Statement report, if we click on Half Yearly it will gives error.
You can check this error in demo

https://demo.erpnext.com/desk#query-report/Profit%20and%20Loss%20Statement

Regards,
sambhaji

This has been fixed in the latest release. It will be deployed on the cloud server tomorrow.

2 Likes

@nabinhait I tested it :smile: and its awesome! Thanks for the update!