Bug fix in permissions system

Hi everyone,


Currently, permission system of ERPNext doesn’t hide table columns (like Amount in Sales Order Item table) based on the combination of field’s permission level and permissions defined for those levels using Permission Manager. We are going to release this fix today at 5 PM IST. (I know it’s a long pending request)

If you find a few columns missing/hidden in forms and print formats after this release, it will be due to this release. Ideally, this will affect only those who have tried to change a field’s permission level for a table using Customize Form. Hence, you will need to modify the field’s permission level from Customize Form for that table’s DocType. For most forms, setting it to 0 will expose the column.

If you are still unable to get it working, please contact us and we will help you sort it out.

Thanks,
Anand Doshi.



You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To post to this group, send email to er...@googlegroups.com.

To unsubscribe from this group, send email to erpnext-developer-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.