Bench Update SSL error

Hi Team,

I created an app and when I do ‘bench update’ I managed to get it pulling updates from github but I get the following error and it sits for a very long time at the last comment before completing successfully…its not causing any error but im worried if this might be causing performance issues.


INFO:bench.app:pulling varmani
From https://github.com/Varmani/varmani

  • branch master -> FETCH_HEAD
    Already up-to-date.
    /home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages

Also not sure if its related to return empty data on response when using the rest api via ssl
test at : https://test.varmani.co.za/api/method/login?usr=guest&pwd=guest

Any feedback will be appreciated

regards
hemant

Hi Hemant,

These are warnings. You can ignore them for now till we fix the underlying dependencies.

I am getting insecure page for the guest access api call.