Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Bench update say An Error occurred while downloading assets... when bench build start

Hi

When I do bench update as usual, I noticed error message shows below

Building assets...
$ bench build
An Error occurred while downloading assets...
yarn run v1.22.10
$ FRAPPE_ENV=production node rollup/build.js
Production mode
✔ Built js/moment-bundle.min.js
✔ Built js/libs.min.js

I searched furnm , someone said process will try to download assets from http://assets.frappeframework.com
I checked that URL via browser, I got certification issue and has been refused.
not sure if it is the reason why bench build can’t download assets.

Thanks.

no, just ensure your running machine can access internet, or if you would like to test, you can execute:

wget http://assets.frappeframework.com/df0143f9482908ee3a0d052803b7aa88dbe97f01.tar.gz

to test it can download or not.

sometimes the that packages can’t download and will show this error, but the bench command will go back to use local assets package for build, so it should no harm.

1 Like

Thanks for the explain. I’m okay with.

Faced the same error and after doing as explained above, it downloaded the files but on bench build the error occurred again… Is this something to worry me or can I safely ignore this error…?