Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Bench update/migrate unable to complete if using postgres

Hello

Im using frappe on v12.x.x-develop ()

To create custom apps, new site was created with: --db-type postgres

All its ok, but now if i ran:
bench update i get this:

mariadb service is not running.
Cannot run bench migrate without the services running.
If you are running bench in development mode, make sure that 
bench is running:

$ bench start

Otherwise, check the server logs and ensure that all the required services are running.

So i’m unable to update or even migrate when using postgres

I’m having this using mariadb running on another server as well.

I solved it by installing mariadb instance on my machine

You might want to read this [Release Notes] ERPNext and Frappe Version 13-beta.4

1 Like