Try ERPNext Buy Support Partners Foundation

Bench update: error: cannot open .git/FETCH_HEAD: Permission denied

Hi all,
I tried update my bench but the following error is occured:

/home/frappe/frappe-bench# bench update
INFO:bench.utils:updating bench
INFO:bench.utils:git pull
error: cannot open .git/FETCH_HEAD: Permission denied

Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/commands/”, line 35, in update
File “/home/frappe/bench-repo/bench/”, line 246, in update_bench
exec_cmd(“git pull”, cwd=cwd)
File “/home/frappe/bench-repo/bench/”, line 130, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull

I also tried to git pull all the apps in my bench: frappe & erpnext & .bench folder, and the all run fine!
any suggestion plz?

seems like the permission issue, please check the permissions to a bench directory

Hi @MaysaaSafadi,

try Sudo bench update


I checked it also and it have all the permissions

I tried it also; the same error

Share the output of frappe & erpnext repos using the following command
git remote -v


That is:
/home/frappe/frappe-bench/apps/frappe# git remote -v
upstream (fetch)
upstream (push)

/home/frappe/frappe-bench/apps/erpnext# git remote -v
upstream (fetch)
upstream (push)

I’m having the same error .

but my git remote -v

output is

fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).