Bench stop and server error

hello,
when i’m using this all command to create new site and app and start bench …it’s stopped

and after start localhost it’s give server error

i used this command but it’s not working…
give me other solution

it says address already i use just kill the ports and try bench start

I have killed process for 12000,11000,13000,8000
it gives following result…

manasvi@manasvi-desktop:/home/frappe/frappe-bench/frappe-bench$ sudo bench start
14:50:11 system | watch.1 started (pid=11534)
14:50:11 system | web.1 started (pid=11535)
14:50:11 system | redis_socketio.1 started (pid=11525)
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 * Increased maximum number of open files to 10032 (it was originally set to 1024).
14:50:11 redis_socketio.1 | .
14:50:11 redis_socketio.1 | .-__ ''-._ 14:50:11 redis_socketio.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
14:50:11 system | worker_long.1 started (pid=11527)
14:50:11 system | worker_short.1 started (pid=11549)
14:50:11 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 14:50:11 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 14:50:11 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 14:50:11 redis_socketio.1 | |-. ._ / _.-' | PID: 11530 14:50:11 redis_socketio.1 |-._ -._-./ .-’ .-’
14:50:11 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 14:50:11 redis_socketio.1 |-._ -._-..-’.-’ .-’
14:50:11 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_socketio.1 | |-.
-._ _.-'_.-' | 14:50:11 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
14:50:11 redis_socketio.1 | -._-..-’ _.-’
14:50:11 redis_socketio.1 | -._ _.-' 14:50:11 redis_socketio.1 |-.
.-’
14:50:11 redis_socketio.1 |
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 # Server started, Redis version 3.0.6
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:50:11 redis_socketio.1 | 11530:M 26 Dec 14:50:11.082 * The server is now ready to accept connections on port 12000
14:50:11 system | worker_default.1 started (pid=11548)
14:50:11 system | schedule.1 started (pid=11543)
14:50:11 system | redis_queue.1 started (pid=11544)
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 * Increased maximum number of open files to 10032 (it was originally set to 1024).
14:50:11 redis_queue.1 | .
14:50:11 redis_queue.1 | .-__ ''-._ 14:50:11 redis_queue.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
14:50:11 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 14:50:11 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 14:50:11 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 14:50:11 redis_queue.1 | |-._ ._ / _.-' | PID: 11551 14:50:11 redis_queue.1 |-._ -._-./ .-’ .-’
14:50:11 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 14:50:11 redis_queue.1 |-._ -._-..-’.-’ .-’
14:50:11 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_queue.1 | |-.
-._ _.-'_.-' | 14:50:11 redis_queue.1 |-._ -._-.
.-’.-’ .-’
14:50:11 redis_queue.1 | -._-..-’ _.-’
14:50:11 redis_queue.1 | -._ _.-' 14:50:11 redis_queue.1 |-.
.-’
14:50:11 redis_queue.1 |
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 # Server started, Redis version 3.0.6
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:50:11 redis_queue.1 | 11551:M 26 Dec 14:50:11.096 * The server is now ready to accept connections on port 11000
14:50:11 system | redis_cache.1 started (pid=11545)
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 * Increased maximum number of open files to 10032 (it was originally set to 1024).
14:50:11 redis_cache.1 | .
14:50:11 redis_cache.1 | .-__ ''-._ 14:50:11 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
14:50:11 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 14:50:11 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 14:50:11 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 14:50:11 redis_cache.1 | |-._ ._ / _.-' | PID: 11560 14:50:11 redis_cache.1 |-._ -._-./ .-’ .-’
14:50:11 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 14:50:11 redis_cache.1 |-._ -._-..-’.-’ .-’
14:50:11 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:50:11 redis_cache.1 | |-.
-._ _.-'_.-' | 14:50:11 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
14:50:11 redis_cache.1 | -._-..-’ _.-’
14:50:11 redis_cache.1 | -._ _.-' 14:50:11 redis_cache.1 |-.
.-’
14:50:11 redis_cache.1 |
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 # Server started, Redis version 3.0.6
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:50:11 redis_cache.1 | 11560:M 26 Dec 14:50:11.118 * The server is now ready to accept connections on port 13000
14:50:11 system | socketio.1 started (pid=11547)
14:50:12 socketio.1 | listening on *: 9000
14:50:14 worker_short.1 | 14:50:14 RQ worker u’rq:worker:manasvi-desktop.11556.short’ started, version 0.9.2
14:50:14 worker_short.1 | 14:50:14 Cleaning registries for queue: short
14:50:14 worker_short.1 | 14:50:14
14:50:14 worker_short.1 | 14:50:14 *** Listening on short…
14:50:14 worker_default.1 | 14:50:14 RQ worker u’rq:worker:manasvi-desktop.11552.default’ started, version 0.9.2
14:50:14 worker_default.1 | 14:50:14 Cleaning registries for queue: default
14:50:14 worker_default.1 | 14:50:14
14:50:14 worker_default.1 | 14:50:14 *** Listening on default…
14:50:14 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
14:50:14 web.1 | * Restarting with inotify reloader
14:50:14 worker_long.1 | 14:50:14 RQ worker u’rq:worker:manasvi-desktop.11532.long’ started, version 0.9.2
14:50:14 worker_long.1 | 14:50:14 Cleaning registries for queue: long
14:50:14 worker_long.1 | 14:50:14
14:50:14 worker_long.1 | 14:50:14 *** Listening on long…
14:50:14 watch.1 | compiling avatar.less
14:50:14 watch.1 | compiling calendar.less
14:50:14 watch.1 | compiling common.less
14:50:14 watch.1 | compiling controls.less
14:50:15 watch.1 | compiling desk.less
14:50:15 web.1 | * Debugger is active!
14:50:15 web.1 | * Debugger PIN: 403-706-844
14:50:15 watch.1 | compiling desktop.less
14:50:15 watch.1 | compiling docs.less
14:50:15 watch.1 | compiling email.less
14:50:15 watch.1 | compiling form.less
14:50:15 watch.1 | compiling form_grid.less
14:50:15 watch.1 | compiling gantt.less
14:50:15 watch.1 | compiling indicator.less
14:50:15 watch.1 | compiling kanban.less
14:50:15 watch.1 | compiling list.less
14:50:15 watch.1 | compiling mixins.less
14:50:15 watch.1 | compiling mobile.less
14:50:15 watch.1 | compiling module.less
14:50:15 watch.1 | compiling navbar.less
14:50:15 watch.1 | compiling page.less
14:50:15 watch.1 | compiling report.less
14:50:15 watch.1 | compiling role_editor.less
14:50:15 watch.1 | compiling sidebar.less
14:50:15 watch.1 | compiling slickgrid.less
14:50:15 watch.1 | compiling tags.less
14:50:15 watch.1 | compiling tree.less
14:50:15 watch.1 | compiling website.less
14:50:15 watch.1 | compiling email.less
14:50:15 watch.1 | compiling erpnext.less
14:50:15 watch.1 | compiling hub.less
14:50:15 watch.1 | compiling pos.less
14:50:15 watch.1 | compiling website.less
14:50:15 watch.1 | events.js:160
14:50:15 watch.1 | throw er; // Unhandled ‘error’ event
14:50:15 watch.1 | ^
14:50:15 watch.1 |
14:50:15 watch.1 | Error: listen EADDRINUSE :::6787
14:50:15 watch.1 | at Object.exports._errnoException (util.js:1020:11)
14:50:15 watch.1 | at exports._exceptionWithHostPort (util.js:1043:20)
14:50:15 watch.1 | at Server._listen2 (net.js:1262:14)
14:50:15 watch.1 | at listen (net.js:1298:10)
14:50:15 watch.1 | at Server.listen (net.js:1394:5)
14:50:15 watch.1 | at watch (/home/frappe/frappe-bench/frappe-bench/apps/frappe/frappe/build.js:53:7)
14:50:15 watch.1 | at Object. (/home/frappe/frappe-bench/frappe-bench/apps/frappe/frappe/build.js:40:2)
14:50:15 watch.1 | at Module._compile (module.js:570:32)
14:50:15 watch.1 | at Object.Module._extensions…js (module.js:579:10)
14:50:15 watch.1 | at Module.load (module.js:487:32)
14:50:15 system | watch.1 stopped (rc=0)
14:50:15 system | sending SIGTERM to redis_socketio.1 (pid 11525)
14:50:15 system | sending SIGTERM to worker_long.1 (pid 11527)
14:50:15 system | sending SIGTERM to redis_queue.1 (pid 11544)
14:50:15 system | sending SIGTERM to web.1 (pid 11535)
14:50:15 system | sending SIGTERM to schedule.1 (pid 11543)
14:50:15 system | sending SIGTERM to worker_default.1 (pid 11548)
14:50:15 system | sending SIGTERM to socketio.1 (pid 11547)
14:50:15 system | sending SIGTERM to redis_cache.1 (pid 11545)
14:50:15 system | sending SIGTERM to worker_short.1 (pid 11549)
14:50:15 worker_default.1 | 14:50:15 Warm shut down requested
14:50:15 redis_socketio.1 | 11530:signal-handler (1514280015) Received SIGTERM scheduling shutdown…
14:50:15 worker_long.1 | 14:50:15 Warm shut down requested
14:50:15 worker_short.1 | 14:50:15 Warm shut down requested
14:50:15 system | schedule.1 stopped (rc=-15)
14:50:15 system | socketio.1 stopped (rc=-15)
14:50:15 redis_queue.1 | 11551:signal-handler (1514280015) Received SIGTERM scheduling shutdown…
14:50:15 redis_cache.1 | 11560:signal-handler (1514280015) Received SIGTERM scheduling shutdown…
14:50:15 redis_cache.1 | 11560:M 26 Dec 14:50:15.245 # User requested shutdown…
14:50:15 redis_cache.1 | 11560:M 26 Dec 14:50:15.245 # Redis is now ready to exit, bye bye…
14:50:15 system | redis_cache.1 stopped (rc=-15)
14:50:15 system | worker_long.1 stopped (rc=-15)
14:50:15 redis_socketio.1 | 11530:M 26 Dec 14:50:15.296 # User requested shutdown…
14:50:15 redis_socketio.1 | 11530:M 26 Dec 14:50:15.296 # Redis is now ready to exit, bye bye…
14:50:15 system | redis_socketio.1 stopped (rc=-15)
14:50:15 redis_queue.1 | 11551:M 26 Dec 14:50:15.306 # User requested shutdown…
14:50:15 redis_queue.1 | 11551:M 26 Dec 14:50:15.306 # Redis is now ready to exit, bye bye…
14:50:15 system | redis_queue.1 stopped (rc=-15)
14:50:15 system | web.1 stopped (rc=-15)
14:50:15 system | worker_default.1 stopped (rc=-15)
14:50:15 system | worker_short.1 stopped (rc=-15)

Do lsof -i :6787 and kill all the process on this port

it workd…
thank u…

1 Like