Bench start with serveral errors

When i start bench start i got the following output:
12:30:27 system | redis_socketio.1 started (pid=1595)
12:30:27 redis_socketio.1 | 1604:M 19 Sep 12:30:27.994 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:30:28 redis_socketio.1 | .
12:30:28 redis_socketio.1 | .-__ ''-._ 12:30:28 redis_socketio.1 | _.- .. ‘’-._ Redis 3.2.6 (00000000/0) 64 bit
12:30:28 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 12:30:28 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 12:30:28 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 12:30:28 redis_socketio.1 | |-. ._ / _.-' | PID: 1604 12:30:28 redis_socketio.1 |-._ -._-./ .-’ .-’
12:30:28 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 12:30:28 redis_socketio.1 |-._ -._-..-’.-’ .-’
12:30:28 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_socketio.1 | |-.
-._ _.-'_.-' | 12:30:28 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
12:30:28 redis_socketio.1 | -._-..-’ _.-’
12:30:28 redis_socketio.1 | -._ _.-' 12:30:28 redis_socketio.1 |-.
.-’
12:30:28 redis_socketio.1 |
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.006 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.006 # Server started, Redis version 3.2.6
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.007 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.007 * The server is now ready to accept connections on port 12000
12:30:28 system | redis_queue.1 started (pid=1605)
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.009 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:30:28 system | schedule.1 started (pid=1606)
12:30:28 system | worker_short.1 started (pid=1609)
12:30:28 redis_queue.1 | .
12:30:28 redis_queue.1 | .-__ ''-._ 12:30:28 redis_queue.1 | _.- .. ‘’-.
Redis 3.2.6 (00000000/0) 64 bit
12:30:28 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 12:30:28 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 12:30:28 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 12:30:28 redis_queue.1 | |-._ ._ / _.-' | PID: 1611 12:30:28 redis_queue.1 |-._ -._-./ .-’ .-’
12:30:28 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 12:30:28 redis_queue.1 |-._ -._-..-’.-’ .-’
12:30:28 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_queue.1 | |-.
-._ _.-'_.-' | 12:30:28 redis_queue.1 |-._ -._-.
.-’.-’ .-’
12:30:28 redis_queue.1 | -._-..-’ _.-’
12:30:28 redis_queue.1 | -._ _.-' 12:30:28 redis_queue.1 |-.
.-’
12:30:28 redis_queue.1 |
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.023 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.023 # Server started, Redis version 3.2.6
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.023 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.023 * The server is now ready to accept connections on port 11000
12:30:28 system | worker_long.1 started (pid=1603)
12:30:28 system | web.1 started (pid=1607)
12:30:28 system | watch.1 started (pid=1610)
12:30:28 system | socketio.1 started (pid=1620)
12:30:28 system | worker_default.1 started (pid=1608)
12:30:28 system | redis_cache.1 started (pid=1624)
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.064 * Increased maximum number of open files to 10032 (it was originally set to 1024).
12:30:28 redis_cache.1 | .
12:30:28 redis_cache.1 | .-__ ''-._ 12:30:28 redis_cache.1 | _.- .. ‘’-.
Redis 3.2.6 (00000000/0) 64 bit
12:30:28 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 12:30:28 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 12:30:28 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 12:30:28 redis_cache.1 | |-._ ._ / _.-' | PID: 1637 12:30:28 redis_cache.1 |-._ -._-./ .-’ .-’
12:30:28 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 12:30:28 redis_cache.1 |-._ -._-..-’.-’ .-’
12:30:28 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 12:30:28 redis_cache.1 | |-.
-._ _.-'_.-' | 12:30:28 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
12:30:28 redis_cache.1 | -._-..-’ _.-’
12:30:28 redis_cache.1 | -._ _.-' 12:30:28 redis_cache.1 |-.
.-’
12:30:28 redis_cache.1 |
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.065 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.065 # Server started, Redis version 3.2.6
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.065 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.065 * The server is now ready to accept connections on port 13000
12:30:28 socketio.1 | module.js:550
12:30:28 socketio.1 | throw err;
12:30:28 socketio.1 | ^
12:30:28 socketio.1 |
12:30:28 socketio.1 | Error: Cannot find module ‘superagent’
12:30:28 socketio.1 | at Function.Module._resolveFilename (module.js:548:15)
12:30:28 socketio.1 | at Function.Module._load (module.js:475:25)
12:30:28 socketio.1 | at Module.require (module.js:597:17)
12:30:28 socketio.1 | at require (internal/module.js:11:18)
12:30:28 socketio.1 | at Object. (/home/bench/bench-repo/erpnext/apps/frappe/socketio.js:7:15)
12:30:28 socketio.1 | at Module._compile (module.js:653:30)
12:30:28 socketio.1 | at Object.Module._extensions…js (module.js:664:10)
12:30:28 socketio.1 | at Module.load (module.js:566:32)
12:30:28 socketio.1 | at tryModuleLoad (module.js:506:12)
12:30:28 socketio.1 | at Function.Module._load (module.js:498:3)
12:30:28 system | socketio.1 stopped (rc=1)
12:30:28 system | sending SIGTERM to redis_socketio.1 (pid 1595)
12:30:28 system | sending SIGTERM to worker_long.1 (pid 1603)
12:30:28 system | sending SIGTERM to watch.1 (pid 1610)
12:30:28 system | sending SIGTERM to redis_queue.1 (pid 1605)
12:30:28 system | sending SIGTERM to web.1 (pid 1607)
12:30:28 system | sending SIGTERM to schedule.1 (pid 1606)
12:30:28 system | sending SIGTERM to worker_default.1 (pid 1608)
12:30:28 system | sending SIGTERM to redis_cache.1 (pid 1624)
12:30:28 system | sending SIGTERM to worker_short.1 (pid 1609)
12:30:28 redis_cache.1 | 1637:signal-handler (1537353028) Received SIGTERM scheduling shutdown…
12:30:28 redis_socketio.1 | 1604:signal-handler (1537353028) Received SIGTERM scheduling shutdown…
12:30:28 redis_queue.1 | 1611:signal-handler (1537353028) Received SIGTERM scheduling shutdown…
12:30:28 system | schedule.1 stopped (rc=-15)
12:30:28 system | worker_short.1 stopped (rc=-15)
12:30:28 system | worker_long.1 stopped (rc=-15)
12:30:28 system | web.1 stopped (rc=-15)
12:30:28 system | worker_default.1 stopped (rc=-15)
12:30:28 system | watch.1 stopped (rc=-15)
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.912 # User requested shutdown…
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.912 * Removing the pid file.
12:30:28 redis_socketio.1 | 1604:M 19 Sep 12:30:28.912 # Redis is now ready to exit, bye bye…
12:30:28 system | redis_socketio.1 stopped (rc=-15)
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.928 # User requested shutdown…
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.928 * Removing the pid file.
12:30:28 redis_queue.1 | 1611:M 19 Sep 12:30:28.928 # Redis is now ready to exit, bye bye…
12:30:28 system | redis_queue.1 stopped (rc=-15)
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.971 # User requested shutdown…
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.971 * Removing the pid file.
12:30:28 redis_cache.1 | 1637:M 19 Sep 12:30:28.971 # Redis is now ready to exit, bye bye…
12:30:28 system | redis_cache.1 stopped (rc=-15)

Please help all installed on a debian server.
And the web-interface is not accessible port settings are good

Greets Hans

Many of such errors have already occurred. Don’t get worried about this long trace. You need to look for specific statements like these:

Error: Cannot find module ‘superagent’

So if you had searched this line in the forum search you would possibly come across these solutions :-

try this solution

npm install babel-core less chokidar babel-preset-es2015 babel-preset-es2016 babel-preset-es2017 babel-preset-babili this was not helping me same errors below you see what is in red:
I don’t see the webpage for the login
08:09:07 socketio.1 | module.js:550
08:09:07 socketio.1 | throw err;
08:09:07 socketio.1 | ^
08:09:07 socketio.1 |
08:09:07 socketio.1 | Error: Cannot find module ‘superagent’
08:09:07 socketio.1 | at Function.Module._resolveFilename (module.js:548:15)
08:09:07 socketio.1 | at Function.Module._load (module.js:475:25)
08:09:07 socketio.1 | at Module.require (module.js:597:17)
08:09:07 socketio.1 | at require (internal/module.js:11:18)
08:09:07 socketio.1 | at Object. (/home/bench/bench-repo/erpnext/apps/frappe/socketio.js:7:15)
08:09:07 socketio.1 | at Module._compile (module.js:653:30)
08:09:07 socketio.1 | at Object.Module._extensions…js (module.js:664:10)
08:09:07 socketio.1 | at Module.load (module.js:566:32)
08:09:07 socketio.1 | at tryModuleLoad (module.js:506:12)
08:09:07 socketio.1 | at Function.Module._load (module.js:498:3)

Some progress now i have executed this npm install -g yarn en restart the bench now in red is the following;

08:33:59 socketio.1 | superagent: Enable experimental feature http2
08:33:59 socketio.1 | (node:3022) ExperimentalWarning: The http2 module is an experimental API.
08:33:59 socketio.1 | listening on *: 9000
08:34:04 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)

stil not a web interface

execute this and also execute bench clear-cache and bench clear-website-cache in your frappe-bench folder

After execute npm install socket.io this is the output;
npm WARN saveError ENOENT: no such file or directory, open ‘/home/frappe/package.json’
npm WARN enoent ENOENT: no such file or directory, open ‘/home/frappe/package.json’
npm WARN frappe No description
npm WARN frappe No repository field.
npm WARN frappe No README data
npm WARN frappe No license field.

  • superagent@4.0.0-beta.5
  • cookie@0.3.1
  • redis@2.8.0
  • socket.io@2.1.1
  • express@4.16.3
    updated 5 packages and audited 536 packages in 7.359s
    found 0 vulnerabilities

Then the cleaning tool is the output;
You should not run this command as root…but i`m root and in the good dir

Thanks

run again the install socket.io output now;
npm WARN frappe No description
npm WARN frappe No repository field.
npm WARN frappe No license field.

  • socket.io@2.1.1
  • superagent@4.0.0-beta.5
  • cookie@0.3.1
  • express@4.16.3
  • redis@2.8.0
    updated 5 packages and audited 225 packages in 2.379s
    found 0 vulnerabilities

nothing sorry still not working.

Sorry no different still not working.

Try this one

I think start all over now! is there not a manuel for debian 9.5 server im really over my hours now. And we want to have erpnext because this a fine product.

1 Like

Probably this will help you:

1 Like