ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

Bench start problem npm error


#1

When I am going to start bench. after this command it is showing like this. please Suggest me what i have to do

bench start

14:20:38 system | worker_long.1 started (pid=30167)
14:20:38 system | redis_cache.1 started (pid=30170)
14:20:38 system | worker_default.1 started (pid=30168)
14:20:38 system | watch.1 started (pid=30163)
14:20:38 system | redis_socketio.1 started (pid=30166)
14:20:38 system | redis_queue.1 started (pid=30169)
14:20:38 system | web.1 started (pid=30174)
14:20:38 system | schedule.1 started (pid=30171)
14:20:38 system | socketio.1 started (pid=30172)
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.899 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.900 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.900 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.900 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.900 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.900 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:20:38 redis_socketio.1 | .
14:20:38 redis_socketio.1 | .-__ ''-._ 14:20:38 redis_socketio.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
14:20:38 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 14:20:38 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 14:20:38 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 14:20:38 redis_socketio.1 | |-. ._ / _.-' | PID: 30179 14:20:38 redis_socketio.1 |-._ -._-./ .-’ .-’
14:20:38 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 14:20:38 redis_socketio.1 |-._ -._-..-’.-’ .-’
14:20:38 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_socketio.1 | |-.
-._ _.-'_.-' | 14:20:38 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
14:20:38 redis_socketio.1 | -._-..-’ _.-’
14:20:38 redis_socketio.1 | -._ _.-' 14:20:38 redis_socketio.1 |-.
.-’
14:20:38 redis_socketio.1 |
14:20:38 redis_queue.1 | .
14:20:38 redis_queue.1 | .-__ ''-._ 14:20:38 redis_queue.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
14:20:38 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 14:20:38 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 14:20:38 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 14:20:38 redis_queue.1 | |-._ ._ / _.-' | PID: 30188 14:20:38 redis_queue.1 |-._ -._-./ .-’ .-’
14:20:38 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 14:20:38 redis_queue.1 |-._ -._-..-’.-’ .-’
14:20:38 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_queue.1 | |-.
-._ _.-'_.-' | 14:20:38 redis_queue.1 |-._ -._-.
.-’.-’ .-’
14:20:38 redis_queue.1 | -._-..-’ _.-’
14:20:38 redis_queue.1 | -._ _.-' 14:20:38 redis_queue.1 |-.
.-’
14:20:38 redis_queue.1 |
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.901 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.901 # Server started, Redis version 3.0.6
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.902 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.902 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.902 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:20:38 redis_queue.1 | 30188:M 13 Jun 14:20:38.902 * The server is now ready to accept connections on port 11000
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.902 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.902 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:20:38 system | worker_short.1 started (pid=30180)
14:20:38 redis_cache.1 | .
14:20:38 redis_cache.1 | .-__ ''-._ 14:20:38 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
14:20:38 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 14:20:38 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 14:20:38 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 14:20:38 redis_cache.1 | |-._ ._ / _.-' | PID: 30186 14:20:38 redis_cache.1 |-._ -._-./ .-’ .-’
14:20:38 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 14:20:38 redis_cache.1 |-._ -._-..-’.-’ .-’
14:20:38 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:20:38 redis_cache.1 | |-.
-._ _.-'_.-' | 14:20:38 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
14:20:38 redis_cache.1 | -._-..-’ _.-’
14:20:38 redis_cache.1 | -._ _.-' 14:20:38 redis_cache.1 |-.
.-’
14:20:38 redis_cache.1 |
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.903 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.903 # Server started, Redis version 3.0.6
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.903 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.903 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:20:38 redis_cache.1 | 30186:M 13 Jun 14:20:38.904 * The server is now ready to accept connections on port 13000
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.904 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.904 # Server started, Redis version 3.0.6
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.904 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.904 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:20:38 redis_socketio.1 | 30179:M 13 Jun 14:20:38.904 * The server is now ready to accept connections on port 12000
14:20:39 socketio.1 | listening on *: 9000
14:20:40 worker_default.1 | 14:20:40 RQ worker u’rq:worker:svr3.30184.default’ started, version 0.8.2
14:20:40 worker_default.1 | 14:20:40 Cleaning registries for queue: default
14:20:40 worker_default.1 | 14:20:40
14:20:40 worker_default.1 | 14:20:40 *** Listening on default…
14:20:40 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
14:20:40 worker_short.1 | 14:20:40 RQ worker u’rq:worker:svr3.30194.short’ started, version 0.8.2
14:20:40 worker_short.1 | 14:20:40 Cleaning registries for queue: short
14:20:40 worker_short.1 | 14:20:40
14:20:40 worker_short.1 | 14:20:40 *** Listening on short…
14:20:40 worker_long.1 | 14:20:40 RQ worker u’rq:worker:svr3.30178.long’ started, version 0.8.2
14:20:40 worker_long.1 | 14:20:40 Cleaning registries for queue: long
14:20:40 worker_long.1 | 14:20:40
14:20:40 worker_long.1 | 14:20:40 *** Listening on long…
14:20:40 web.1 | * Restarting with inotify reloader
14:20:41 watch.1 |
14:20:41 watch.1 | > frappe@ watch /home/rekhas/frappe-bench/apps/frappe
14:20:41 watch.1 | > node rollup/watch.js
14:20:41 watch.1 |
14:20:41 web.1 | * Debugger is active!
14:20:41 web.1 | * Debugger PIN: 294-746-059
14:20:41 watch.1 |
14:20:41 watch.1 | Rollup Watcher Started
14:20:41 watch.1 |
14:20:41 watch.1 | Watching…
14:20:42 watch.1 | Rebuilding frappe-web.css
14:20:42 watch.1 | Rebuilding frappe-web.min.js
14:20:46 watch.1 | Rebuilding control.min.js
14:20:46 watch.1 | Rebuilding dialog.min.js
14:20:48 watch.1 | Rebuilding desk.min.css
14:20:48 watch.1 | events.js:160
14:20:48 watch.1 | throw er; // Unhandled ‘error’ event
14:20:48 watch.1 | ^
14:20:48 watch.1 |
14:20:48 watch.1 | Error: watch /home/rekhas/frappe-bench/apps/frappe/frappe/public/less/mobile.less ENOSPC
14:20:48 watch.1 | at exports._errnoException (util.js:1022:11)
14:20:48 watch.1 | at FSWatcher.start (fs.js:1429:19)
14:20:48 watch.1 | at Object.fs.watch (fs.js:1456:11)
14:20:48 watch.1 | at createFsWatchInstance (/home/rekhas/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:37:15)
14:20:48 watch.1 | at setFsWatchListener (/home/rekhas/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15)
14:20:48 watch.1 | at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/rekhas/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:228:14)
14:20:48 watch.1 | at FSWatcher.NodeFsHandler._handleFile (/home/rekhas/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:255:21)
14:20:48 watch.1 | at FSWatcher. (/home/rekhas/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:473:21)
14:20:48 watch.1 | at FSReqWrap.oncomplete (fs.js:123:15)
14:20:48 watch.1 |
14:20:48 watch.1 | npm ERR! Linux 4.13.0-32-generic
14:20:48 watch.1 | npm ERR! argv “/home/rekhas/.nvm/versions/node/v6.9.5/bin/node” “/home/rekhas/.nvm/versions/node/v6.9.5/bin/npm” “run” “watch”
14:20:48 watch.1 | npm ERR! node v6.9.5
14:20:48 watch.1 | npm ERR! npm v3.10.10
14:20:48 watch.1 | npm ERR! code ELIFECYCLE
14:20:48 watch.1 | npm ERR! frappe@ watch: node rollup/watch.js
14:20:48 watch.1 | npm ERR! Exit status 1
14:20:48 watch.1 | npm ERR!
14:20:48 watch.1 | npm ERR! Failed at the frappe@ watch script ‘node rollup/watch.js’.
14:20:48 watch.1 | npm ERR! Make sure you have the latest version of node.js and npm installed.
14:20:48 watch.1 | npm ERR! If you do, this is most likely a problem with the frappe package,
14:20:48 watch.1 | npm ERR! not with npm itself.
14:20:48 watch.1 | npm ERR! Tell the author that this fails on your system:
14:20:48 watch.1 | npm ERR! node rollup/watch.js
14:20:48 watch.1 | npm ERR! You can get information on how to open an issue for this project with:
14:20:48 watch.1 | npm ERR! npm bugs frappe
14:20:48 watch.1 | npm ERR! Or if that isn’t available, you can get their info via:
14:20:48 watch.1 | npm ERR! npm owner ls frappe
14:20:48 watch.1 | npm ERR! There is likely additional logging output above.
14:20:48 watch.1 |
14:20:48 watch.1 | npm ERR! Please include the following file with any support request:
14:20:48 watch.1 | npm ERR! /home/rekhas/frappe-bench/apps/frappe/npm-debug.log
14:20:48 system | watch.1 stopped (rc=0)
14:20:48 system | sending SIGTERM to redis_socketio.1 (pid 30166)
14:20:48 system | sending SIGTERM to worker_long.1 (pid 30167)
14:20:48 system | sending SIGTERM to redis_queue.1 (pid 30169)
14:20:48 system | sending SIGTERM to web.1 (pid 30174)
14:20:48 system | sending SIGTERM to schedule.1 (pid 30171)
14:20:48 system | sending SIGTERM to worker_default.1 (pid 30168)
14:20:48 system | sending SIGTERM to socketio.1 (pid 30172)
14:20:48 system | sending SIGTERM to redis_cache.1 (pid 30170)
14:20:48 system | sending SIGTERM to worker_short.1 (pid 30180)
14:20:48 redis_socketio.1 | 30179:signal-handler (1528879848) Received SIGTERM scheduling shutdown…
14:20:48 worker_long.1 | 14:20:48 Warm shut down requested
14:20:48 redis_queue.1 | 30188:signal-handler (1528879848) Received SIGTERM scheduling shutdown…
14:20:48 worker_default.1 | 14:20:48 Warm shut down requested
14:20:48 redis_cache.1 | 30186:signal-handler (1528879848) Received SIGTERM scheduling shutdown…
14:20:48 system | schedule.1 stopped (rc=-15)
14:20:48 worker_short.1 | 14:20:48 Warm shut down requested
14:20:48 system | socketio.1 stopped (rc=-15)
14:20:48 redis_queue.1 | 30188:M 13 Jun 14:20:48.217 # User requested shutdown…
14:20:48 redis_queue.1 | 30188:M 13 Jun 14:20:48.217 # Redis is now ready to exit, bye bye…
14:20:48 system | redis_queue.1 stopped (rc=-15)
14:20:48 redis_cache.1 | 30186:M 13 Jun 14:20:48.218 # User requested shutdown…
14:20:48 redis_cache.1 | 30186:M 13 Jun 14:20:48.218 # Redis is now ready to exit, bye bye…
14:20:48 system | redis_cache.1 stopped (rc=-15)
14:20:48 system | worker_long.1 stopped (rc=-15)
14:20:48 system | worker_default.1 stopped (rc=-15)
14:20:48 system | worker_short.1 stopped (rc=-15)
14:20:48 system | web.1 stopped (rc=-15)
14:20:48 redis_socketio.1 | 30179:M 13 Jun 14:20:48.269 # User requested shutdown…
14:20:48 redis_socketio.1 | 30179:M 13 Jun 14:20:48.269 # Redis is now ready to exit, bye bye…
14:20:48 system | redis_socketio.1 stopped (rc=-15)
re


Bench start with serveral errors
#2

use this command:
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p


Not able to run the application after installing the application freshly
#3

Thank you so much sir,
now it’s working fine after run this command


#4