Bench start problem ERPNext7 on CentOS7

manual setup ERPNext7 on CentOS7, install complete,I input “bench start” command.it likes start on debugger mode.command running until press ctrl+c to break.but website don’t work.have you a way? to start service but not a debugger?

14:29:50 system | redis_socketio.1 started (pid=4475)
14:29:50 system | worker_long.1 started (pid=4478)
14:29:50 system | web.1 started (pid=4481)
14:29:50 system | redis_cache.1 started (pid=4487)
14:29:50 system | worker_short.1 started (pid=4494)
14:29:50 system | socketio.1 started (pid=4493)
14:29:50 system | redis_queue.1 started (pid=4490)
14:29:50 system | worker_default.1 started (pid=4492)
14:29:50 system | schedule.1 started (pid=4485)
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # Current maximum open files is 1024. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:29:50 redis_queue.1 | .
14:29:50 redis_queue.1 | .-__ ''-._ 14:29:50 redis_queue.1 | _.- .. ‘’-._ Redis 2.8.19 (00000000/0) 64 bit
14:29:50 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 14:29:50 redis_queue.1 | ( ' , .-` | `, ) Running in stand alone mode 14:29:50 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 14:29:50 redis_queue.1 | |-. ._ / _.-' | PID: 4490 14:29:50 redis_queue.1 |-._ -._-./ .-’ .-’
14:29:50 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 14:29:50 redis_queue.1 |-._ -._-..-’.-’ .-’
14:29:50 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_queue.1 | |-.
-._ _.-'_.-' | 14:29:50 redis_queue.1 |-._ -._-.
.-’.-’ .-’
14:29:50 redis_queue.1 | -._-..-’ _.-’
14:29:50 redis_queue.1 | -._ _.-' 14:29:50 redis_queue.1 |-.
.-’
14:29:50 redis_queue.1 |
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # Server started, Redis version 2.8.19
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:29:50 redis_queue.1 | [4490] 17 Aug 14:29:50.682 * The server is now ready to accept connections on port 11000
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # Current maximum open files is 1024. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:29:50 redis_socketio.1 | .
14:29:50 redis_socketio.1 | .-__ ''-._ 14:29:50 redis_socketio.1 | _.- .. ‘’-.
Redis 2.8.19 (00000000/0) 64 bit
14:29:50 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 14:29:50 redis_socketio.1 | ( ' , .-` | `, ) Running in stand alone mode 14:29:50 redis_socketio.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 12000 14:29:50 redis_socketio.1 | |-._ ._ / _.-' | PID: 4475 14:29:50 redis_socketio.1 |-._ -._-./ .-’ .-’
14:29:50 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 14:29:50 redis_socketio.1 |-._ -._-..-’.-’ .-’
14:29:50 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_socketio.1 | |-.
-._ _.-'_.-' | 14:29:50 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
14:29:50 redis_socketio.1 | -._-..-’ _.-’
14:29:50 redis_socketio.1 | -._ _.-' 14:29:50 redis_socketio.1 |-.
.-’
14:29:50 redis_socketio.1 |
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # Server started, Redis version 2.8.19
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:29:50 redis_socketio.1 | [4475] 17 Aug 14:29:50.691 * The server is now ready to accept connections on port 12000
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # Current maximum open files is 1024. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:29:50 redis_cache.1 | .
14:29:50 redis_cache.1 | .-__ ''-._ 14:29:50 redis_cache.1 | _.- .. ‘’-.
Redis 2.8.19 (00000000/0) 64 bit
14:29:50 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 14:29:50 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 14:29:50 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 14:29:50 redis_cache.1 | |-._ ._ / _.-' | PID: 4487 14:29:50 redis_cache.1 |-._ -._-./ .-’ .-’
14:29:50 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 14:29:50 redis_cache.1 |-._ -._-..-’.-’ .-’
14:29:50 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 14:29:50 redis_cache.1 | |-.
-._ _.-'_.-' | 14:29:50 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
14:29:50 redis_cache.1 | -._-..-’ _.-’
14:29:50 redis_cache.1 | -._ _.-' 14:29:50 redis_cache.1 |-.
.-’
14:29:50 redis_cache.1 |
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # Server started, Redis version 2.8.19
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.686 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:29:50 redis_cache.1 | [4487] 17 Aug 14:29:50.687 * The server is now ready to accept connections on port 13000
14:29:50 system | watch.1 started (pid=4489)
14:29:52 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
14:29:53 worker_long.1 | 14:29:53 RQ worker u’rq:worker:localhost.localdomain.4478.long’ started, version 0.6.0
14:29:53 worker_default.1 | 14:29:53 RQ worker u’rq:worker:localhost.localdomain.4492.default’ started, version 0.6.0
14:29:53 worker_long.1 | 14:29:53 Cleaning registries for queue: long
14:29:53 worker_default.1 | 14:29:53 Cleaning registries for queue: default
14:29:53 worker_long.1 | 14:29:53
14:29:53 worker_long.1 | 14:29:53 *** Listening on long…
14:29:53 worker_default.1 | 14:29:53
14:29:53 worker_default.1 | 14:29:53 *** Listening on default…
14:29:53 worker_short.1 | 14:29:53 RQ worker u’rq:worker:localhost.localdomain.4494.short’ started, version 0.6.0
14:29:53 worker_short.1 | 14:29:53 Cleaning registries for queue: short
14:29:53 worker_short.1 | 14:29:53
14:29:53 worker_short.1 | 14:29:53 *** Listening on short…
14:29:53 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
14:29:53 watch.1 | Wrote ./assets/js/form.min.js - 172k
14:29:53 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
14:29:53 watch.1 | Wrote ./assets/js/report.min.js - 248k
14:29:53 web.1 | * Restarting with inotify reloader
14:29:53 watch.1 | Wrote ./assets/js/erpnext.min.js - 88k
14:29:53 watch.1 | Wrote ./assets/css/list.min.css - 7k
14:29:53 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
14:29:53 watch.1 | Wrote ./assets/js/d3.min.js - 380k
14:29:53 watch.1 | Wrote ./assets/css/report.min.css - 7k
14:29:53 watch.1 | Wrote ./assets/css/frappe-web.css - 53k
14:29:53 watch.1 | Wrote ./assets/js/list.min.js - 104k
14:29:53 watch.1 | Wrote ./assets/js/dialog.min.js - 80k
14:29:53 watch.1 | Wrote ./assets/js/desk.min.js - 313k
14:29:53 watch.1 | Wrote ./assets/css/form.min.css - 4k
14:29:54 watch.1 | Wrote ./assets/js/editor.min.js - 45k
14:29:54 watch.1 | Wrote ./assets/css/erpnext.css - 3k
14:29:54 web.1 | * Debugger is active!
14:29:54 web.1 | * Debugger pin code: 153-928-068
14:29:54 watch.1 | Wrote ./assets/js/libs.min.js - 887k
14:29:54 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
14:29:54 watch.1 | Wrote ./assets/css/desk.min.css - 263k
14:29:54 watch.1 | Wrote ./assets/css/module.min.css - 2k
14:29:54 socketio.1 | listening on *: 9000

It’s nobody?

This is now working! Go to localhost:8000 on your browser :slight_smile:

1 Like