ERPNext Conference 2019* ERPNext.com Blog

Bench start failed anyone can help?


#1

khaled@khaled-Latitude-5590:~/frappe-bench$ bench start
10:36:29 system | redis_cache.1 started (pid=5005)
10:36:29 system | redis_socketio.1 started (pid=5007)
10:36:29 redis_cache.1 | 5009:C 06 Oct 10:36:29.472 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
10:36:29 redis_cache.1 | 5009:C 06 Oct 10:36:29.472 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5009, just started
10:36:29 redis_cache.1 | 5009:C 06 Oct 10:36:29.472 # Configuration loaded
10:36:29 redis_socketio.1 | 5013:C 06 Oct 10:36:29.473 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
10:36:29 redis_socketio.1 | 5013:C 06 Oct 10:36:29.473 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5013, just started
10:36:29 redis_socketio.1 | 5013:C 06 Oct 10:36:29.473 # Configuration loaded
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.473 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.473 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.473 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 * Running mode=standalone, port=13000.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 # Server initialized
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10:36:29 redis_cache.1 | 5009:M 06 Oct 10:36:29.474 * Ready to accept connections
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 * Running mode=standalone, port=12000.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # Server initialized
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.474 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10:36:29 redis_socketio.1 | 5013:M 06 Oct 10:36:29.475 * Ready to accept connections
10:36:29 system | socketio.1 started (pid=5017)
10:36:29 system | redis_queue.1 started (pid=5012)
10:36:29 redis_queue.1 | 5029:C 06 Oct 10:36:29.476 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
10:36:29 redis_queue.1 | 5029:C 06 Oct 10:36:29.476 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5029, just started
10:36:29 redis_queue.1 | 5029:C 06 Oct 10:36:29.476 # Configuration loaded
10:36:29 system | watch.1 started (pid=5019)
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.477 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.477 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.477 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 * Running mode=standalone, port=11000.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 # Server initialized
10:36:29 system | web.1 started (pid=5015)
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10:36:29 redis_queue.1 | 5029:M 06 Oct 10:36:29.478 * Ready to accept connections
10:36:29 system | worker_short.1 started (pid=5037)
10:36:29 system | worker_default.1 started (pid=5039)
10:36:29 system | worker_long.1 started (pid=5038)
10:36:29 system | schedule.1 started (pid=5034)
10:36:30 socketio.1 | listening on *: 9000
10:36:31 watch.1 | yarn run v1.19.0
10:36:32 watch.1 | $ node rollup/watch.js
10:36:32 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
10:36:32 web.1 | * Restarting with inotify reloader
10:36:32 watch.1 | /home/khaled/frappe-bench/apps/frappe/rollup/config.js:52
10:36:32 watch.1 | vue.default(),
10:36:32 watch.1 | ^
10:36:32 watch.1 |
10:36:32 watch.1 | TypeError: vue.default is not a function
10:36:32 watch.1 | at get_rollup_options_for_js (/home/khaled/frappe-bench/apps/frappe/rollup/config.js:52:14)
10:36:32 watch.1 | at get_rollup_options (/home/khaled/frappe-bench/apps/frappe/rollup/config.js:29:10)
10:36:32 watch.1 | at Object.keys.map.output_file (/home/khaled/frappe-bench/apps/frappe/rollup/config.js:174:5)
10:36:32 watch.1 | at Array.map ()
10:36:32 watch.1 | at get_options_for (/home/khaled/frappe-bench/apps/frappe/rollup/config.js:162:4)
10:36:32 watch.1 | at get_watch_options (/home/khaled/frappe-bench/apps/frappe/rollup/watch.js:57:18)
10:36:32 watch.1 | at apps_list.map.app (/home/khaled/frappe-bench/apps/frappe/rollup/watch.js:21:24)
10:36:32 watch.1 | at Array.map ()
10:36:32 watch.1 | at watch_assets (/home/khaled/frappe-bench/apps/frappe/rollup/watch.js:20:12)
10:36:32 watch.1 | at Object. (/home/khaled/frappe-bench/apps/frappe/rollup/watch.js:16:1)
10:36:32 watch.1 | at Module._compile (module.js:653:30)
10:36:32 watch.1 | at Object.Module._extensions…js (module.js:664:10)
10:36:32 watch.1 | at Module.load (module.js:566:32)
10:36:32 watch.1 | at tryModuleLoad (module.js:506:12)
10:36:32 watch.1 | at Function.Module._load (module.js:498:3)
10:36:32 watch.1 | at Function.Module.runMain (module.js:694:10)
10:36:32 watch.1 | error Command failed with exit code 1.
10:36:32 watch.1 | info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
10:36:32 system | watch.1 stopped (rc=0)
10:36:32 system | sending SIGTERM to redis_cache.1 (pid 5005)
10:36:32 system | sending SIGTERM to redis_socketio.1 (pid 5007)
10:36:32 system | sending SIGTERM to redis_queue.1 (pid 5012)
10:36:32 system | sending SIGTERM to web.1 (pid 5015)
10:36:32 system | sending SIGTERM to socketio.1 (pid 5017)
10:36:32 system | sending SIGTERM to schedule.1 (pid 5034)
10:36:32 system | sending SIGTERM to worker_short.1 (pid 5037)
10:36:32 system | sending SIGTERM to worker_long.1 (pid 5038)
10:36:32 system | sending SIGTERM to worker_default.1 (pid 5039)
10:36:32 redis_cache.1 | 5009:signal-handler (1570350992) Received SIGTERM scheduling shutdown…
10:36:32 redis_socketio.1 | 5013:signal-handler (1570350992) Received SIGTERM scheduling shutdown…
10:36:32 redis_queue.1 | 5029:signal-handler (1570350992) Received SIGTERM scheduling shutdown…
10:36:32 worker_long.1 | 10:36:32 Warm shut down requested
10:36:32 worker_short.1 | 10:36:32 Warm shut down requested
10:36:32 worker_default.1 | 10:36:32 Warm shut down requested
10:36:32 system | socketio.1 stopped (rc=-15)
10:36:32 system | schedule.1 stopped (rc=-15)
10:36:32 redis_cache.1 | 5009:M 06 Oct 10:36:32.779 # User requested shutdown…
10:36:32 redis_cache.1 | 5009:M 06 Oct 10:36:32.779 * Removing the pid file.
10:36:32 redis_cache.1 | 5009:M 06 Oct 10:36:32.779 # Redis is now ready to exit, bye bye…
10:36:32 redis_socketio.1 | 5013:M 06 Oct 10:36:32.780 # User requested shutdown…
10:36:32 system | redis_cache.1 stopped (rc=-15)
10:36:32 redis_socketio.1 | 5013:M 06 Oct 10:36:32.780 * Removing the pid file.
10:36:32 redis_socketio.1 | 5013:M 06 Oct 10:36:32.780 # Redis is now ready to exit, bye bye…
10:36:32 system | redis_socketio.1 stopped (rc=-15)
10:36:32 redis_queue.1 | 5029:M 06 Oct 10:36:32.784 # User requested shutdown…
10:36:32 redis_queue.1 | 5029:M 06 Oct 10:36:32.785 * Removing the pid file.
10:36:32 redis_queue.1 | 5029:M 06 Oct 10:36:32.785 # Redis is now ready to exit, bye bye…
10:36:32 system | redis_queue.1 stopped (rc=-15)
10:36:32 system | worker_short.1 stopped (rc=-15)
10:36:32 system | worker_long.1 stopped (rc=-15)
10:36:32 system | worker_default.1 stopped (rc=-15)
10:36:32 system | web.1 stopped (rc=-15)


#2

Try this…

sudo supervisorctl restart all

If that still doesn’t help, then

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p;
sudo supervisorctl restart all

#3

thanks