Bench start errors

bench start

19:10:15 system           | redis_socketio.1 started (pid=3810)
19:10:15 system           | worker_long.1 started (pid=3811)
19:10:15 system           | web.1 started (pid=3820)
19:10:15 redis_socketio.1 | 3822:C 19 Apr 19:10:15.087 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:10:15 redis_socketio.1 | 3822:C 19 Apr 19:10:15.087 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3822, just started
19:10:15 redis_socketio.1 | 3822:C 19 Apr 19:10:15.087 # Configuration loaded
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.088 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:10:15 system           | redis_queue.1 started (pid=3824)
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.088 * Running mode=standalone, port=12000.
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.088 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.089 # Server initialized
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.089 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.089 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.089 * Ready to accept connections
19:10:15 system           | watch.1 started (pid=3813)
19:10:15 redis_queue.1    | 3832:C 19 Apr 19:10:15.091 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:10:15 redis_queue.1    | 3832:C 19 Apr 19:10:15.091 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3832, just started
19:10:15 redis_queue.1    | 3832:C 19 Apr 19:10:15.092 # Configuration loaded
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.092 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.093 * Running mode=standalone, port=11000.
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.093 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.093 # Server initialized
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.093 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.094 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.094 * Ready to accept connections
19:10:15 system           | worker_default.1 started (pid=3827)
19:10:15 system           | schedule.1 started (pid=3826)
19:10:15 system           | socketio.1 started (pid=3830)
19:10:15 socketio.1       | /bin/sh: 1: None: not found
19:10:15 system           | socketio.1 stopped (rc=127)
19:10:15 system           | worker_short.1 started (pid=3829)
19:10:15 system           | redis_cache.1 started (pid=3831)
19:10:15 system           | sending SIGTERM to redis_socketio.1 (pid 3810)
19:10:15 system           | sending SIGTERM to worker_long.1 (pid 3811)
19:10:15 system           | sending SIGTERM to watch.1 (pid 3813)
19:10:15 system           | sending SIGTERM to redis_queue.1 (pid 3824)
19:10:15 system           | sending SIGTERM to web.1 (pid 3820)
19:10:15 system           | sending SIGTERM to schedule.1 (pid 3826)
19:10:15 system           | sending SIGTERM to worker_default.1 (pid 3827)
19:10:15 system           | sending SIGTERM to redis_cache.1 (pid 3831)
19:10:15 system           | sending SIGTERM to worker_short.1 (pid 3829)
19:10:15 redis_cache.1    | 3847:C 19 Apr 19:10:15.107 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:10:15 redis_cache.1    | 3847:C 19 Apr 19:10:15.107 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3847, just started
19:10:15 redis_cache.1    | 3847:C 19 Apr 19:10:15.107 # Configuration loaded
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 * Running mode=standalone, port=13000.
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 # Server initialized
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.108 * Ready to accept connections
19:10:15 redis_socketio.1 | 3822:signal-handler (1587316215) Received SIGTERM scheduling shutdown...
19:10:15 redis_queue.1    | 3832:signal-handler (1587316215) Received SIGTERM scheduling shutdown...
19:10:15 system           | web.1 stopped (rc=-15)
19:10:15 redis_cache.1    | 3847:signal-handler (1587316215) Received SIGTERM scheduling shutdown...
19:10:15 system           | worker_short.1 stopped (rc=-15)
19:10:15 system           | schedule.1 stopped (rc=-15)
19:10:15 system           | worker_long.1 stopped (rc=-15)
19:10:15 system           | worker_default.1 stopped (rc=-15)
19:10:15 system           | watch.1 stopped (rc=-15)
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.189 # User requested shutdown...
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.189 * Removing the pid file.
19:10:15 redis_socketio.1 | 3822:M 19 Apr 19:10:15.189 # Redis is now ready to exit, bye bye...
19:10:15 system           | redis_socketio.1 stopped (rc=-15)
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.194 # User requested shutdown...
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.194 * Removing the pid file.
19:10:15 redis_queue.1    | 3832:M 19 Apr 19:10:15.194 # Redis is now ready to exit, bye bye...
19:10:15 system           | redis_queue.1 stopped (rc=-15)
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.211 # User requested shutdown...
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.211 * Removing the pid file.
19:10:15 redis_cache.1    | 3847:M 19 Apr 19:10:15.211 # Redis is now ready to exit, bye bye...
19:10:15 system           | redis_cache.1 stopped (rc=-15)

The same startup traceback here

Please give details of your host environment, is this a fresh install that refuses to run, or has bench start only now started to fail. You may want to redo your install or manual setup

2 Likes

it’s likely that yarn isn’t in $PATH. Can you check if bench build works for you or if yarn exists?

1 Like

With this too Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]

For the record what say you please for all to benefit?