ERPNext Conference 2019* Blog

Bench Start error in erpnext


bench start
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/opt/erpnext/bench-repo/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1134, in invoke
Command.invoke(self, ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/opt/erpnext/bench-repo/bench/commands/”, line 30, in bench_command
File “/opt/erpnext/bench-repo/bench/”, line 13, in set_frappe_version
FRAPPE_VERSION = get_current_frappe_version(bench_path=bench_path)
File “/opt/erpnext/bench-repo/bench/”, line 275, in get_current_frappe_version
return get_major_version(get_current_version(‘frappe’, bench_path=bench_path))
File “/opt/erpnext/bench-repo/bench/”, line 315, in get_current_version
return get_version_from_string(, field=‘version’)
File “/opt/erpnext/bench-repo/bench/”, line 408, in get_version_from_string
AttributeError: ‘NoneType’ object has no attribute ‘group’


Try This

Go to bench-repo folder
git pull origin
Go back to frappe-bench folder
Run bench update --reset


I tried this…But not working It shows same error