Bench start command is not working!

Hello Guys!!

I have faced issue while performed bench start command in develop branch.

/workspace/erpnext/frappe-bench$ bench start

Please see below descriptions:

17:16:31 system | redis_socketio.1 started (pid=3423)
17:16:31 redis_socketio.1 | 3430:C 11 Dec 17:16:31.169 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
17:16:31 redis_socketio.1 | 3430:C 11 Dec 17:16:31.169 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3430, just started
17:16:31 redis_socketio.1 | 3430:C 11 Dec 17:16:31.169 # Configuration loaded
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.170 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.170 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.170 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 * Running mode=standalone, port=12000.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 # Server initialized
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:16:31 redis_socketio.1 | 3430:M 11 Dec 17:16:31.171 * Ready to accept connections
17:16:31 system | watch.1 started (pid=3426)
17:16:31 system | worker_long.1 started (pid=3425)
17:16:31 system | schedule.1 started (pid=3433)
17:16:31 system | redis_queue.1 started (pid=3441)
17:16:31 redis_queue.1 | 3444:C 11 Dec 17:16:31.184 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
17:16:31 redis_queue.1 | 3444:C 11 Dec 17:16:31.184 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3444, just started
17:16:31 redis_queue.1 | 3444:C 11 Dec 17:16:31.184 # Configuration loaded
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.187 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.187 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.187 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 * Running mode=standalone, port=11000.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 # Server initialized
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:16:31 redis_queue.1 | 3444:M 11 Dec 17:16:31.188 * Ready to accept connections
17:16:31 system | socketio.1 started (pid=3440)
17:16:31 system | worker_default.1 started (pid=3457)
17:16:31 system | web.1 started (pid=3460)
17:16:31 system | redis_cache.1 started (pid=3463)
17:16:31 redis_cache.1 | 3466:C 11 Dec 17:16:31.259 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
17:16:31 redis_cache.1 | 3466:C 11 Dec 17:16:31.259 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=3466, just started
17:16:31 redis_cache.1 | 3466:C 11 Dec 17:16:31.259 # Configuration loaded
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 * Running mode=standalone, port=13000.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # Server initialized
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:16:31 redis_cache.1 | 3466:M 11 Dec 17:16:31.261 * Ready to accept connections
17:16:31 system | worker_short.1 started (pid=3464)
17:16:32 socketio.1 | listening on *: 9000
17:16:35 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
17:16:35 web.1 | * Restarting with inotify reloader
17:16:35 watch.1 | yarn run v1.12.3
17:16:35 watch.1 | $ node rollup/watch.js
17:16:36 web.1 | * Debugger is active!
17:16:36 web.1 | * Debugger PIN: 189-455-974
17:16:36 watch.1 |
17:16:36 watch.1 | Rollup Watcher Started
17:16:36 watch.1 |
17:16:36 watch.1 | Watching…
17:16:37 watch.1 | Rebuilding frappe-web.css
17:16:37 watch.1 | events.js:174
17:16:37 watch.1 | throw er; // Unhandled ‘error’ event
17:16:37 watch.1 | ^
17:16:37 watch.1 |
17:16:37 watch.1 | Error: ENOSPC: System limit for number of file watchers reached, watch ‘/home/serpentcs/workspace/erpnext/frappe-bench/apps/frappe/frappe/public/css/font-awesome.css’
17:16:37 watch.1 | at FSWatcher.start (internal/fs/watchers.js:165:26)
17:16:37 watch.1 | at Object.watch (fs.js:1276:11)
17:16:37 watch.1 | at createFsWatchInstance (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:37:15)
17:16:37 watch.1 | at setFsWatchListener (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15)
17:16:37 watch.1 | at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:228:14)
17:16:37 watch.1 | at FSWatcher.NodeFsHandler._handleFile (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:255:21)
17:16:37 watch.1 | at FSWatcher. (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:473:21)
17:16:37 watch.1 | at FSReqCallback.oncomplete (fs.js:161:5)
17:16:37 watch.1 | Emitted ‘error’ event at:
17:16:37 watch.1 | at FSWatcher._handleError (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/index.js:257:10)
17:16:37 watch.1 | at createFsWatchInstance (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:39:5)
17:16:37 watch.1 | at setFsWatchListener (/home/serpentcs/workspace/erpnext/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15)
17:16:37 watch.1 | [… lines matching original stack trace …]
17:16:37 watch.1 | at FSReqCallback.oncomplete (fs.js:161:5)
17:16:37 watch.1 | error Command failed with exit code 1.
17:16:37 watch.1 | info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
17:16:37 system | watch.1 stopped (rc=0)
17:16:37 system | sending SIGTERM to redis_socketio.1 (pid 3423)
17:16:37 system | sending SIGTERM to worker_long.1 (pid 3425)
17:16:37 system | sending SIGTERM to redis_queue.1 (pid 3441)
17:16:37 system | sending SIGTERM to web.1 (pid 3460)
17:16:37 system | sending SIGTERM to schedule.1 (pid 3433)
17:16:37 system | sending SIGTERM to worker_default.1 (pid 3457)
17:16:37 system | sending SIGTERM to socketio.1 (pid 3440)
17:16:37 system | sending SIGTERM to redis_cache.1 (pid 3463)
17:16:37 system | sending SIGTERM to worker_short.1 (pid 3464)
17:16:37 redis_socketio.1 | 3430:signal-handler (1544528797) Received SIGTERM scheduling shutdown…
17:16:37 redis_queue.1 | 3444:signal-handler (1544528797) Received SIGTERM scheduling shutdown…
17:16:37 worker_short.1 | 17:16:37 Warm shut down requested
17:16:37 worker_long.1 | 17:16:37 Warm shut down requested
17:16:37 system | socketio.1 stopped (rc=-15)
17:16:37 redis_cache.1 | 3466:signal-handler (1544528797) Received SIGTERM scheduling shutdown…
17:16:37 system | schedule.1 stopped (rc=-15)
17:16:37 worker_default.1 | 17:16:37 Warm shut down requested
17:16:37 redis_cache.1 | 3466:M 11 Dec 17:16:37.579 # User requested shutdown…
17:16:37 redis_cache.1 | 3466:M 11 Dec 17:16:37.579 * Removing the pid file.
17:16:37 redis_cache.1 | 3466:M 11 Dec 17:16:37.579 # Redis is now ready to exit, bye bye…
17:16:37 system | redis_cache.1 stopped (rc=-15)
17:16:37 redis_socketio.1 | 3430:M 11 Dec 17:16:37.589 # User requested shutdown…
17:16:37 redis_socketio.1 | 3430:M 11 Dec 17:16:37.589 * Removing the pid file.
17:16:37 redis_socketio.1 | 3430:M 11 Dec 17:16:37.589 # Redis is now ready to exit, bye bye…
17:16:37 system | redis_socketio.1 stopped (rc=-15)
17:16:37 redis_queue.1 | 3444:M 11 Dec 17:16:37.608 # User requested shutdown…
17:16:37 redis_queue.1 | 3444:M 11 Dec 17:16:37.608 * Removing the pid file.
17:16:37 redis_queue.1 | 3444:M 11 Dec 17:16:37.608 # Redis is now ready to exit, bye bye…
17:16:37 system | redis_queue.1 stopped (rc=-15)
17:16:37 system | worker_short.1 stopped (rc=-15)
17:16:37 system | worker_default.1 stopped (rc=-15)
17:16:37 system | worker_long.1 stopped (rc=-15)
17:16:38 system | web.1 stopped (rc=-15)

Please give me any solution for that.

Thank You.

1 Like

Try this
Run the following command on shell prompt
“echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p”

5 Likes

Thank You @sagar for givining solution. !!

3 Likes